Last Comment Bug 620272 - Sometimes can't replay WAV
: Sometimes can't replay WAV
Status: RESOLVED WORKSFORME
:
Product: Toolkit
Classification: Components
Component: Video/Audio Controls (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jared Wein [:jaws] (please needinfo? me)
Mentors:
http://people.xiph.org/~xiphmont/demo...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-19 13:02 PST by Chris Pearce (:cpearce)
Modified: 2012-08-23 16:56 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Chris Pearce (:cpearce) 2010-12-19 13:02:22 PST
[Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20101219 Firefox/4.0b9pre]

At http://people.xiph.org/~xiphmont/demo/celt/demo.html there are two WAV files in audio elements. If you play both of the elements using their controls simultaneously a few times, eventually you'll not be able to replay the first one.

STR:
1. Load http://people.xiph.org/~xiphmont/demo/celt/demo.html
2. Scroll down to the section "Why low delay?"
3. Play "Sample 1" and "Sample 2" approximately simultaneously by clicking on the elements' play buttons in quick succession. Once both elements have played to the end, repeat a few times.
4. Try to play "Sample 1" by clicking on its play button, it may not play (if it does play, repeat step 3 a few more times).

The audio elements are playing WAV files, not Ogg, so it could be the case that there's an event the videocontrols are exepecting that the nsBuiltinDecoder backend sends that the nsWavDecoder isn't sending.
Comment 1 Jim Jeffery not reading bug-mail 1/2/11 2010-12-19 13:26:05 PST
I can't repo using today's nightly.
Comment 2 Matthew Gregan [:kinetik] 2012-08-23 16:56:41 PDT
nsWaveDecoder was replaced in bug 635649, and I can't reproduce this in a current build.

Note You need to log in before you can comment on or make changes to this bug.