If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[d3d9] Animation and UI performance suffers with hardware acceleration enabled

RESOLVED DUPLICATE of bug 595671

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 595671
7 years ago
7 years ago

People

(Reporter: IU, Unassigned)

Tracking

({perf, regression})

Trunk
x86
Windows XP
perf, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Animation and UI performance suffers when hardware acceleration enabled.  Note that this is a different case than bug 615063, which alleges better performance with hardware acceleration enabled.

I originally commented in bug 595671; however, I believe the is different enough that it needs its own bug report.

Here is a copy-and-paste of my original post:

*** NOTE: These are my findings on Windows XP SP3 ***

After some investigation, I've found that disabling hardware acceleration (layers.accelerate-all;false) improves performance.  Ironic, isn't it? 

In terms of CPU utilization, the improvement is not quite as good as it was prior to the regression noted in comment 13; however, in terms of animation speed and UI lag, performance is comparable what it was prior to the regression.

First, the system specs:
------------------------
Motherboard: Asus M4A89GTD PRO USB 3
Memory: 4 GB DDR3 PC-12800
Processor: AMD Athlon II X4 630 (2.8 GHz)
Graphics: Integrated Radeon HD 4200 (AMD 890GX chipset)
Hard Drive: 1 TB WD10EARS
OS: Windows XP PRO SP3
Graphics Driver: Catalyst 10.12
DirectX 9.0c


All testing conducted using attachment 493683 [details] ("Gif Animation Performance testcase")

STR:
1. Download and unzip the testcase 
2. Start Minefield with a new profile
3. load gif-overload.htm
4. Scroll the page down so that nothing above the tile and text, "Man plays games on world's largest LED screen," (blue box on right-hand side) is visible.  The point is to have as many animations in view as possible
5. Note animation speed and CPU utilization
6. Click the File menu and quickly drag the mouse pointer up-and-down the menu list.  Note the UI responsiveness.
7. Disable hardware acceleration (layers.accelerate-all;false)
8. Restart the browser. "Quit" on session saving prompt
9. Repeat steps 3 to 6.


My results (December 19 build):
===============================

HW Acceleration enabled:
------------------------
CPU Utilization: 25-26 %
UI Responsiveness: Very laggy

HW Acceleration disabled:
-------------------------
CPU Utilization: 17-20 %
UI Responsiveness: reasonably responsive


For comparison, April 26 (pre-regression) results:
==================================================
CPU Utilization: 9-13 %
UI Responsiveness: responsive
(Reporter)

Comment 1

7 years ago
Created attachment 498645 [details]
Gif Animation Performance testcase (taken from bug 595671)
(Reporter)

Updated

7 years ago
Blocks: 581212
blocking2.0: --- → ?
(Reporter)

Updated

7 years ago
Keywords: perf, regression
IU, can you paste the contents of your about:support Graphics section?
(Reporter)

Comment 3

7 years ago
(In reply to comment #2)
> IU, can you paste the contents of your about:support Graphics section?

Adapter Description: ATI Radeon HD 4290
Vendor ID: 1002
Device ID: 9714
Adapter RAM: Unknown
Adapter Drivers: ati2dvag
Driver Version: 8.780.0.0
Driver Date: 9-10-2010
Direct2D Enabled: false
DirectWrite Enabled: false
WebGL Renderer: TransGaming Inc. -- ANGLE -- OpenGL ES 2.0 (git-devel Jan  5 2011 03:42:41)
GPU Accelerated Windows: 2/2 Direct3D 9
(Reporter)

Comment 4

7 years ago
In case anyone wonders about the discrepancy in driver version between comment 0 and comment 3: I had to revert to Catalyst 10.10, because ATI/AMD introduced a bug, in subsequent releases, that caused occasional lockup-up and BSOD.

And I have just double-checked my numbers with today's nightly -- just to make sure the display driver version made no difference.  The numbers and performance is the same as noted in comment 0
I'm pretty sure this is just a duplicate of bug 595671. IU, if you've got a strong belief that they're different, feel free to reopen, but were I you I'd wait until that bug is fixed to see if it also fixes your problem.
Status: NEW → RESOLVED
blocking2.0: ? → ---
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 595671
(Reporter)

Comment 6

7 years ago
I really don't believe it's a dupe, but I'll wait and see.

Do you know if anyone is every bothering with bug 595671?  I'm not so confident that bug is going to be fixed prior to release, as there's been no activity.

Comment 7

7 years ago
this is not solved i can see the same behavior with with layers
layers.accelerate-all = false rendering speed in the Gif Animation improves significantly now :)

Nvidia G92 Forceware 644.35 WHQL

Comment 8

7 years ago
So technically with layers layers.accelerate-all = false the Gif Animation problem would be fixed for me though CPU utilization is still very high but it doesn't impact the animation speed so i would say fixed :D
(Reporter)

Comment 9

7 years ago
(In reply to comment #8)
> ...so i would say fixed :D

If it requires that hardware acceleration be disabled, it's not fixed.  The whole point is to have hardware acceleration enabled by default.

The point of this bug report was to point out that hardware acceleration degraded, rather than improved, performance on Windows XP.  That it got duped to bug 595671 I do not believe is correct; and that bug 595671 has been marked as a "softblocker," I believe, is a mistake and a disaster in the making, and I have long doubted that it would get fixed.

But like I said, I'll wait and see.

Comment 10

7 years ago
I gave up on Hardware acceleration for XP since since some time now and practically the use is 0 for Firefox on XP currently the same though is the case with Chrome as the devs decided to disable acceleration for XP since some time now :( 
As long as for example Tab Candy doesn't get accelerated under XP it seems to have 0 use at least for my use case, the small amount of CPU time layers.accelerate-all saved me on some sites mostly when scrolling is to less for being of any use.
Just my Personal Opinion but if you want Hardware acceleration with Firefox you would have to move to Vista or 7 XP most probably never gonna get the real interesting benefits of it.
You need to log in before you can comment on or make changes to this bug.