build with --enable-leaky fails to compile

VERIFIED INVALID

Status

SeaMonkey
Build Config
P3
normal
VERIFIED INVALID
17 years ago
13 years ago

People

(Reporter: spayne, Assigned: cls)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.17-ide i686)
BuildID:    M18

compile fails 

Reproducible: Always
Steps to Reproduce:
1.make clean
2../configure --host=i686-linux --enable-leaky
3.make

Actual Results:  make[1]: Entering directory `/home/sean/mozilla/tools/leaky'
bfd.cpp
c++ -o bfd.o -c -DOSTYPE=\"Linux2.2\" -DOJI  -I../../dist/include    
-I/usr/X11R6/include   -fPIC  -fno-rtti -fno-exceptions -Wall -Wconversion
-Wpointer-arith -Wbad-function-cast -Wcast-align -Woverloaded-virtual -Wsynth
-pedantic -Wno-long-long -pthread  -DDEBUG -DDEBUG_sean -DTRACING -g
-DMOZILLA_CLIENT -include ../../config-defs.h -Wp,-MD,.deps/bfd.pp bfd.cpp
bfd.cpp:18: bfd.h: No such file or directory


Expected Results:  It should compile.

Either bdf.h should have been in the cvs checkout or the build environment
should be such that bfd.h is not included.
(Assignee)

Comment 1

17 years ago
This is not a bug in mozilla.  bfd.h comes from the GNU binutils package.  If it
is not installed on your system, then you have an improper binutils
installation.  (If you are using debian, try the binutils-dev package.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

17 years ago
agreed that fixed the compile.

Thanks

Comment 3

17 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.