Closed Bug 620444 Opened 9 years ago Closed 7 years ago

update push to mirrors automation to handle new process

Categories

(Release Engineering :: Release Automation: Other, defect, P5)

x86_64
Linux
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 785965

People

(Reporter: bhearsum, Unassigned)

References

Details

Recently we gained the ability to push files only to Mozilla mirrors. This is something that we should build into our "push to mirrors" automation. The new process looks like this:
To get files only on Mozilla mirrors:
* Update /pub/mozilla.org/zz/rsyncd-mozilla-releases.exclude with an exclude line for the release that will be pushed. For example, "- firefox/releases/4.0b8". Note that this must be above the "+" lines towards the end of that file.
* Wait 15 minutes
* Run normal rsync from candidates directory to releases/

Afterwards, to get files on community mirrors:
* Remove exclude line from /pub/mozilla.org/zz/rsyncd-mozilla-releases.exclude
* Update /pub/mozilla.org/zz/rsyncd-mozilla-current.exclude (stable branch releases + betas only)

Rail, I'm assigning this bug to you since you wrote the push to mirrors automation.
Blocks: 478420
Priority: -- → P5
For betas we have *b* wildcard, so there is no need to manupulate rsyncd.conf for betas.

Fore releases we also need to change the logic so it handles pushing index.html files properly.

Not sure if I can work on this bug this Q. Back to pool.
Assignee: rail → nobody
Duplicate of this bug: 664171
found in triage.
Component: Release Engineering → Release Engineering: Automation
QA Contact: release → catlee
Bulk move of bugs to Release Automation component.
Component: Release Engineering: Automation (General) → Release Engineering: Automation (Release Automation)
Mass move of bugs to Release Automation component.
No longer blocks: hg-automation
Duplicate of this bug: 637805
Depends on: 736464
We're automating all of this and updating docs in bug 785965.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 785965
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.