The text for the current CountSummary view is confusing: "number of bugs (1-10) to display for each group of days (1-30, or All)" (from http://brasstacks.mozilla.com/couchdb/orange_factor/_design/woo/orange.html?display=CountSummary ) This text should be changed to give a better description of what people are actually looking at. Also, the number of bugs and the days should match what's in the text and the period selector should probably just be three choices instead of having a "Days:" selector
Until such time as bug 621231 is fixed, I changed the text to the following: "full set of each X-day period's top Y bugs" unless X == 1, in which case it's just "full set of each day's top Y bugs". I think that, while it sounds a bit funny, it's more accurate than week/month.
Created attachment 500908 [details] [diff] [review] Better TopBugs (aka CountSummary) subtitle
Comment on attachment 500908 [details] [diff] [review] Better TopBugs (aka CountSummary) subtitle i'd prefer this logic live in its own function, but this is fine.
I've leave it as is unless we decide we need to reuse this logic. Also, while re-reviewing this, I decided to slip in a <p></p> around the text (spaces it out from the graph a bit) and centered the bar labels. Pushed as http://hg.mozilla.org/automation/orangefactor/rev/e61b97288d50