Closed Bug 620471 Opened 12 years ago Closed 11 years ago

Figure out why Mozrunner 2.5.2/jsbridge 2.4.1/MozMill 1.5.1 doesn't work for Thunderbird

Categories

(Testing Graveyard :: Mozmill, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 656736

People

(Reporter: standard8, Assigned: standard8)

References

Details

(Whiteboard: [mozmill-2.0+])

I've seen this several times on our builders, and keep forgetting to work it out. Therefore filing bug so I remember.

The details. Using the following versions:

mozrunner: 2.5.2
jsbridge: 2.4.1
mozmill: 1.5.1

MozMill fails to run properly on the Thunderbird tinderboxes.

Typical errors are:

INFO | (runtestlist.py) | Running directory: account
['python', 'runtest.py', '-t', 'account', '--binary', '.././Shredder.app', '--symbols-path', '../symbols']
WARNING | endRunner was never called. There must have been a failure in the framework.
NEXT ERROR TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run

or:

['python', 'runtest.py', '-t', 'account', '--binary', '.././Shredder.app', '--symbols-path', '../symbols']
error: uncaptured python exception, closing channel <jsbridge.network.Bridge 127.0.0.1:24242 at 0x1011cea28> (<class 'socket.error'>:[Errno 9] Bad file descriptor [/tools/python/lib/python2.6/asyncore.py|readwrite|107] [/tools/python/lib/python2.6/asyncore.py|handle_expt_event|441] [<string>|getsockopt|1] [/tools/python/lib/python2.6/socket.py|_dummy|165])
error: uncaptured python exception, closing channel <jsbridge.network.BackChannel 127.0.0.1:24242 at 0x1011cef80> (<class 'socket.error'>:[Errno 9] Bad file descriptor [/tools/python/lib/python2.6/asyncore.py|readwrite|107] [/tools/python/lib/python2.6/asyncore.py|handle_expt_event|441] [<string>|getsockopt|1] [/tools/python/lib/python2.6/socket.py|_dummy|165])
WARNING | endRunner was never called. There must have been a failure in the framework.
NEXT ERROR TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run
INFO | (runtestlist.py) | account: 0 passed, 0 failed

For reference, these versions do work:

mozrunner: 2.5.2
jsbridge: 2.3.7b1
mozmill: 1.4.2b1

So I'm suspecting there's something in the jsbridge/mozmill code that's upsetting us, I need to work out what.
Could you also test with 1.4.2b2 and later beta releases for all packages? Would be good to nail down possible checkins.
This problem still exists with 1.5.2 RC1.
Does anyone know if this failure happens in mozmill trunk (mozmill 2.0)?  There has been a lot of refactoring around the mozrunner and stopping code.
Whiteboard: [mozmill-2.0?]
Could anyone point to a singular thunderbird test to try?  they are no longer in the hg.m.o/qa/mozmill-tests
(In reply to comment #4)
> Could anyone point to a singular thunderbird test to try?  they are no longer
> in the hg.m.o/qa/mozmill-tests

I did some work last week to ensure that 1.5.2 ran fine on Thunderbird, so that's solved.  However, I'm not clear if 2.0 does.  Leaving this bug open until we hear back from that investigation.  

The tbird tests are in the comm central tree.  https://developer.mozilla.org/en/Thunderbird/Thunderbird_MozMill_Testing
Whiteboard: [mozmill-2.0?] → [mozmill-2.0+]
see also https://bugzilla.mozilla.org/show_bug.cgi?id=656736

Unsure how these are related, exactly
See Also: → 656736
We're green with MozMill 1.5.4 now when the fix in bug 656736 is included. Duping.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 656736
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.