Don't automatically filter by category

VERIFIED FIXED in 5.12.6

Status

addons.mozilla.org Graveyard
Search
P2
normal
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: fligtar, Assigned: jbalogh)

Tracking

Details

(Reporter)

Description

7 years ago
The new search box doesn't make it obvious that you're searching in the specific category you're in, so you don't realize how limited results are unless you notice the facets already set.

We should only automatically filter by add-on type, e.g. when browsing personas, themes, extensions, collections we can set the add-on type facet.
Target Milestone: 5.12.6 → 4.x (triaged)
(Reporter)

Comment 1

7 years ago
Please do this in the next release. There are very few things more important than major usability issues and frustrations that will affect many non-developer users of the site. This is caused by the new header and had I had time to fully QA the new header I would have blocked the launch on it.
Target Milestone: 4.x (triaged) → 5.12.6

Comment 2

7 years ago
I see the usability issues with search in the new design. However, I am not convinced that this is worthy of blocking a release (as mentioned in comment 2). Most regular users of AMO, would expect search to work the same way as before.

I haven't seen any major complaints in the forums about this. Have you?

I would argue that we keep this as is, until we fix Bug 618622 as this allows users to find extensions easily.
(Reporter)

Comment 3

7 years ago
I don't think anyone, even previous users of AMO, would expect their search results to be limited to a category, even if they're currently browsing that category. Fixing this bug will fix bug 618622 enough, but fixing that bug won't do anything to improve this bug.
(Assignee)

Comment 4

7 years ago
http://github.com/jbalogh/zamboni/commit/a6dad2e
Assignee: nobody → jbalogh
(Assignee)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Comment 5

7 years ago
verified @https://addons.allizom.org/en-US/firefox/extensions/alerts-updates/

checked for diff apps and locales.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.