Attached cookperm.txt does not populate Image Manager.

RESOLVED FIXED

Status

()

Core
Networking: Cookies
P3
normal
RESOLVED FIXED
18 years ago
17 years ago

People

(Reporter: Peter Janes, Assigned: Stephen P. Morse)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.16-22 i686; en-US; m18) Gecko/20001205
BuildID:    2000120508

The attached cookperm.txt does not populate the Image Manager.  You can delete
any single line and the Image Manager will be populated correctly.

Reproducible: Always
Steps to Reproduce:
1. Place this cookperm.txt in a new user directory that has image and cookie
loading set to prompt.
2. Start Mozilla and open the Image Manager.  Notice the window is empty.
3. Exit Mozilla and edit the file to remove a line (say the first, www.ground.com).
4. Start Mozilla and open the Image Manager.  Notice the window is populated
properly.

Actual Results:  The Image Manager window is empty, but Cookie Manager has
content.  (If cookies have actually been set, the Cookie List will also have
content.)

Expected Results:  Both before and after removing lines, the Image Manager
should show all of the sites.

This is a very reduced version of my cookperm.txt.  I haven't exhaustively
tested removing each of the 230+ entries, but the 10 random ones I removed
caused the behaviour described.
(Reporter)

Comment 1

18 years ago
Created attachment 20244 [details]
cookperm.txt file mentioned in bug report
(Reporter)

Comment 2

18 years ago
I forgot to clip the JavaScript error that appears when the image manager is
opened:
chrome://communicator/content/wallet/CookieViewer.js line 384: imgStr has no
properties

This appears similar to bug 62053, which I entered earlier this evening, but the
file does not have any addresses that contain numbers at all, even internally.
->Cookies
Assignee: mstoltz → morse
Component: Security: General → Cookies
QA Contact: ckritzer → tever
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Whiteboard: [x]
(Assignee)

Comment 4

17 years ago
I see the problem.  There's a hard-coded limit on the size of a buffer in 
nsCookie.cpp (search for BUFLEN2).  I'm working on it and should have a fix by 
the end of the day.
(Assignee)

Comment 5

17 years ago
*** Bug 58977 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 6

17 years ago
*** Bug 60567 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 7

17 years ago
*** Bug 62053 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 8

17 years ago
Attaching patches for the following files:

  extensions/cookie/nsCookie.cpp:
  extensions/wallet/src/wallet.cpp
  extensions/wallet/src/singsign.cpp
  extensions/wallet/cookieviewer/CookieViewer.js

The offending file was nsCookie.cpp with its hard-coded BUFLEN2.  The patch for 
nsCookie.cpp fixes the problem.  However similar code used to exist in 
wallet.cpp and singsign.cpp but apparently was removed at one time.  However the 
definition of BUFLEN2/BUFLEN3 were never removed from those files, so they are 
being removed now.

Furthermore, initially I suspected the problem was in CookieViewer.js since 
that's where the javascript error was coming from.  So in an attempt to not be 
mislead by all the javascript warnings, I sprinkled some "var"s into that file 
thereby eliminating the warnings.  It would be a shame to lose this cleanup so 
I'm including the patch for that as well.
(Assignee)

Comment 9

17 years ago
Created attachment 20527 [details] [diff] [review]
Patch for nsCookie.cpp, wallet.cpp, singsign.cpp, & CookieViewer.js

Comment 10

17 years ago
Your description makes sense and the patch looks like
it does what was described. If it tests out, r:pnunn.
(sorry the r: took so long.)
-p
(Assignee)

Updated

17 years ago
Whiteboard: [x] → [w]

Comment 11

17 years ago
sr=alecf
thanks for cleaning this up
(Assignee)

Comment 12

17 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 13

17 years ago
*** Bug 63622 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 14

17 years ago
*** Bug 64275 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

17 years ago
Whiteboard: [w]
You need to log in before you can comment on or make changes to this bug.