Closed Bug 620575 Opened 10 years ago Closed 2 years ago

Standard keyboard shortcuts present in the UI not present in notification pop-up

Categories

(Firefox :: Keyboard Navigation, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: avi.w.levy, Unassigned)

References

Details

Attachments

(4 files)

User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0b9pre) Gecko/20101218 Firefox/4.0b9pre
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0b9pre) Gecko/20101218 Firefox/4.0b9pre

What follows are several manifestations of this bug.

I installed ad block plus; after it had finished downloading, the notification bar popped-up, asking if I want to restart now. I tabbed over to the "Restart Now" button and pressed space, which normally is the shortcut key to trigger a button submit. Enter didn't work either.

Later, I submitted a password form element, and the notification bar asked me if I want firefox to "Remember my password". As before, I tabbed over to the button and pressed both space/enter to no avail. This functionality is present for all other buttons in the UI that I can think of. For example:

I navigate to Edit->Preferences and open up the preferences window. I shift-tab to the "Close" button, and press space. This triggers a button-press and closes the window. This keyboard shortcut is common to most GTK applications I can think of.

Reproducible: Always

Steps to Reproduce:
1. Trigger notification pop-up window
2. Tab over to any button in the pop-up window
3. The usual keyboard bindings are not present

I can think of two simple ways to reproduce 1. off the top of my head:
1a. Submit a password form element on any webpage
1b. Install any add-on
Actual Results:  
No keyboard bindings present

Expected Results:  
Keyboard bindings (space-bar in particular) to be present for button elements in the UI
Attached file about:buildconfig
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 575279
Wrong bar. Sorry.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
I read through https://bugzilla.mozilla.org/show_bug.cgi?id=575279 and I don't think this bug is a duplicate. Can you explain why you think it is?

(This bug is about the missing key-binding to press a selected button; the other bug is about missing menu shortcut keys as far as I can tell)
Another example of the desired behavior:
navigate to about:addons and search for anything in the search bar
Three buttons appear: {"Name", "Last Updated", "Best Match"}
Tab to these buttons; the space-bar triggers enters just as would be expected.
Just updated to latest nightly and the issue appears fixed. Can anyone else duplicate this bug?
I believe this is about the doorhanger keyboard navigation issues that are currently present and have not been resolved to a consistent user experience yet.
Status: REOPENED → NEW
Component: Disability Access → Keyboard Navigation
QA Contact: disability.access → keyboard.navigation
If this is simply a matter of assigning keyboard bindings for some UI elements in the doorhanger (i.e. an unfinished task), I would be willing to help out. Can you point me in the right direction?
I think this sounds like a dupe of bug 595271. Does bug 595271 comment 7 explain the issue you're having?
Do you really think that the styling is the issue all along? The reason why I filed this bug was to say that the doorhanger is not keyboard-accessible under Linux. Attached are three screenshots showing the behavior of the doorhanger custom split-button as I tab to it and use alt-down to access the menu. However, these are the only keyboard shortcuts that work, as far as I'm aware. I understand that the doorhanger is still a work in progress, and I was wondering what would be the easiest way to contribute to this myself?
Attached image Image 1
Attached image Image 2
Attached image Image 3
Duplicate of this bug: 641166
The reporter noted in comment 6 that this appears to be fixed. Also, we don't have the type="menu-button" buttons in doorhangers any more; there is a separate button to open the menu. Closing.
Status: NEW → RESOLVED
Closed: 10 years ago2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.