starting private browsing from jumplist does not update that label correctly

RESOLVED WORKSFORME

Status

()

Firefox
Private Browsing
RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: Christian Ascheberg, Assigned: Away for a while)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [post-2.0])

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.0; rv:2.0b9pre) Gecko/20101220 Firefox/4.0b9pre
Build Identifier: Mozilla/5.0 (Windows NT 6.0; rv:2.0b9pre) Gecko/20101220 Firefox/4.0b9pre

If you select "Enter private browsing" from the Win7 jumplist, Firefox opens in PB mode, but the jumplist item is still labeled "Enter private browsing" instead of "Quit private browsing".
Clicking it switches to non-PB mode, everything is labeled correctly from then on.

Reproducible: Always

Steps to Reproduce:
1. select jumplist item "Enter private browsing"
2. when Firefox is open, look at jumplist again
Actual Results:  
jumplist item is still labeled "Enter private browsing"

Expected Results:  
jumplist item should be labeled "Quit private browsing"
(Reporter)

Comment 1

7 years ago
The fix for bug 603272 made the jumplist item work again at all.
Version: unspecified → Trunk
(Reporter)

Comment 2

7 years ago
Important info: Firefox really needs to be closed before step 1, so that firefox starts after clicking the entry.
(Assignee)

Updated

7 years ago
Assignee: nobody → ehsan
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Whiteboard: [post-2.0]
Duplicate of this bug: 810184
(Reporter)

Comment 4

5 years ago
The problematic jumplist item does not exist anymore, due to the new per-window private browsing mode.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.