Closed Bug 620655 Opened 9 years ago Closed 5 months ago

Hide "See More Add-ons" button after installing all extra add-ons

Categories

(Firefox for Android Graveyard :: General, defect, minor)

ARM
All
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: ahoza, Assigned: mfinkle)

Details

Attachments

(1 file)

Device: Nokia N900
BuildId: Mozilla /5.0 (Maemo;Linux armv7l;rv:2.0b8pre)Gecko/20101220 Firefox/4.0b8pre Fennec /4.0b3pre 

Steps to reproduce:

1. Open Fennec.
2. Go to Preferences->Add-ons and tap "See More Add-ons"
3. Install one of the add-ons displayed after tapping "See More Add-ons"
4. Restart.
5. Install the remaining add-ons provided by "See More Add-ons".
6. Restart.

Expected results:
After step 6, "See More Add-ons" is hidden just like after step 2. 

Actual results:
After step 2, button is hidden. 
After step 6, button is available but nothing happens while tapping on it since there aren't any other suggestions to offer. The button should be hidden/disabled in this situation.
Correction, the build I used is: BuildId: Mozilla /5.0 (Maemo;Linux armv7l;rv:2.0b8pre)Gecko/20101220 Firefox/4.0b9pre Fennec /4.0b4pre
Assignee: nobody → mark.finkle
Attached patch patchSplinter Review
Check right away if there are enough add-ons to need a "Show More" button. If not, hide it.
Attachment #499081 - Flags: review?(21)
pushed:
http://hg.mozilla.org/mobile-browser/rev/a8f3c9a3be91
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
I'm still seeing the behavior on build:
Mozilla/5.0 (Android; Linux armv71; rv:2.0b9pre) Gecko/20101227 Namoroka/4.0b9pre Fennec/4.0b4pre
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Closing all opened bug in a graveyard component
Status: REOPENED → RESOLVED
Closed: 9 years ago5 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.