Closed Bug 620683 Opened 9 years ago Closed 9 years ago

Star button flashes distractingly when switching tabs, loading pages, going back or forward, etc.

Categories

(Firefox :: Bookmarks & History, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 4.0b9

People

(Reporter: dao, Assigned: dao)

References

Details

(Keywords: polish, regression)

Attachments

(1 file)

Bug 613477 made updates to the star button async and therefore hides the star between the update request and the actual update. That hiding seems unnecessarily noisy and should be avoided.
Severity: trivial → normal
Summary: Star button flashes distractingly when switching tabs, navigating, going back or forward, etc. → Star button flashes distractingly when switching tabs, loading pages, going back or forward, etc.
The alternative would be to disable the star, but disabled status would not be easy to distiguish from not bookmarked status. And a throbber looks exagerated for this case (and perf problematic). Both solutions would still flicker too.

Since the time needed for the update is usually really short, but not predictable, I think we cannot just trust that the user won't click on it before it has been updated.
fwiw, I don't even notice the star unless I am explicitly looking at it, the new gray star is practically invisible to my peripheral view.
(In reply to comment #1)
> The alternative would be to disable the star, but disabled status would not be
> easy to distiguish from not bookmarked status. And a throbber looks exagerated
> for this case (and perf problematic). Both solutions would still flicker too.

Right, we don't want it to flicker, so why bother at all? Just disable it without actually styling it disabled.
I think the solution was discarded because a click op on it in this "special" state would be completely no-op, it would just appear as a broken piece of UI. But we can re-evaluate that solution if ux is fine with that.
also, Ideally it should not flicker when switching tabs even with async since status is cached, so that could be the real bug to fix.
(In reply to comment #4)
> I think the solution was discarded because a click op on it in this "special"
> state would be completely no-op, it would just appear as a broken piece of UI.

This seems like an extreme edge case not worth optimizing for.

(In reply to comment #5)
> also, Ideally it should not flicker when switching tabs even with async since
> status is cached, so that could be the real bug to fix.

I actually noticed this at first when going back (using bfcache).
Btw, what happens if a user hits Ctrl+D while the star is updating? This case, while still an edge case, might be slightly easier to hit than clicking the star button while it's updating. To handle that I think you really want to disable the command.
Blocks: 560198
Attached patch patchSplinter Review
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #499545 - Flags: review?
Attachment #499545 - Flags: review? → review?(mak77)
Attachment #499545 - Flags: review?(mak77) → review+
Attachment #499545 - Flags: approval2.0?
Attachment #499545 - Flags: approval2.0? → approval2.0+
http://hg.mozilla.org/mozilla-central/rev/5d7d04e98fa9
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b9
You need to log in before you can comment on or make changes to this bug.