The Body style tag does not get processed if it is included from a linked style sheet.

VERIFIED DUPLICATE of bug 62075

Status

()

Core
CSS Parsing and Computation
P3
normal
VERIFIED DUPLICATE of bug 62075
18 years ago
18 years ago

People

(Reporter: Mark Scott, Assigned: Pierre Saslawsky)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Give the following example we get a page that all the style information is
ignored, i.e. we get "some text" on a white page with normal margins.

test.html
<html>
<head>
<link rel="stylesheet" type="text/css"
      href="style.css"
      title="merlin style">
<body>
some text
</body>
</html>

style.css
<style>
<!--
BODY {
  margin-top: 100px;
  margin-right: 10px;
  margin-bottom: 10px;
  margin-left: 100px;
  background: red;
}
-->
</style>

but if we have a page, as below all works correctly.

<html>
<head>
<style>
<!--
BODY {
margin-top: 100px;
margin-right: 10px;
margin-bottom: 10px;
margin-left: 100px;
background: red;
}
-->
</style>
<body>
some text
</body>
</html>

*** This bug has been marked as a duplicate of 62075 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
verify dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.