Key events need to be converted to Unicode before propagation

VERIFIED FIXED in M7

Status

()

Core
Internationalization
P3
normal
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: Simon Fraser, Assigned: tague)

Tracking

Trunk
All
Mac System 8.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
The char field of the nsKeyEvent should contain a Unicode character; currently,
it's being set with an ASCII char (possibly 8-bit); this may differ between
plaforms.

This needs fixing on each platform.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 1

19 years ago
*** Bug 7538 has been marked as a duplicate of this bug. ***

Comment 2

19 years ago
Assuming that Bug 7538 is a duplicate of this bug, I supplied
one set of reproducible steps for that bug report.
(Assignee)

Comment 3

19 years ago
bulk move to M9
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 4

19 years ago
I verified this in 6-28-08-M8 Mac build.

Updated

19 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.