When a recent image is inserted in a second article, this image is deleted

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: scoobidiver, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
I had this issue several times but I didn't know exactly what STR were. Now I know.

STR:
1. Create an article
2. Create several images: image1.png, image2.png
3. Insert these images in the article
4. Submit it for review and approve it
5. Create a second article
6. Insert image1.png
7. Preview it: image1.png does not exist
8. If you go to the image gallery, you'll be prompted with an auto saved draft for the deleted image
Are you certain you'd finished submitting image1.png in the gallery? The autosaved draft occurs when you haven't finished saving an image yet.
(Reporter)

Comment 2

8 years ago
> Are you certain you'd finished submitting image1.png in the gallery?
Yes. If not, I couldn't have seen the inserted image in the first article.
(In reply to comment #2)
> Yes. If not, I couldn't have seen the inserted image in the first article.

The way drafts work, I'm not certain that's actually true. If you did [[Image:draft-123456]] it would probably work.
We could add an is_draft column instead of using the title to determine. That would help clean things up, but with the added complexity.
(Reporter)

Comment 5

8 years ago
> If you did [[Image:draft-123456]] it would probably work.
No, because the image has immediatly its final name, that is image1.png.
When you preview the second article, it is deleted and recreated as an autosaved draft with no name.
Depends on: 623429
(In reply to comment #5)
> No, because the image has immediatly its final name, that is image1.png.
> When you preview the second article, it is deleted and recreated as an
> autosaved draft with no name.
Can you link to the image in the gallery? Can you find it at all, anywhere?
(Reporter)

Comment 7

8 years ago
Following STRs in comment 0, I can not reproduce on:
https://support.allizom.org/en-US (SUMO 2.4.2+).
Closing this per comment 7.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 9

8 years ago
I can still reproduce in 2.4.2. Here are my STR:
* Yesterday, I created and inserted "gestionnaire-téléchargements.png" image in "Utiliser le gestionnaire de téléchargements" article
* Today, I was translating "Favicons do not display" in French. I wanted to insert a new image, so I clicked on "Media Gallery" link and I've got the following thing (see screenshot).
* I checked in "Utiliser le gestionnaire de téléchargements" article and I have the message: The image "gestionnaire-téléchargements.png" does not exist.

May be it is fixed in 2.4.3 but let's wait before reopening it.
(Reporter)

Comment 10

8 years ago
Created attachment 506733 [details]
Screenshot of the warning message
You need to log in before you can comment on or make changes to this bug.