Image is displayed or not according to its name and location

RESOLVED INVALID

Status

()

Core
Graphics
--
minor
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: pascal.lemaitre, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 ( .NET CLR 3.5.30729)

When I create a page to display an image, the image is not displayed if its path is images/aff-stg-2000-thumb.jpg. 
But the very same image is displayed if the filename is images/tst-stg-2000-thumb.jpg.
In Internet Explorer 7 all the various image filenames are displayed correctly.
In Firefox, all the images are displayed if the site is on the local filesytem, but one of them is not displayed when I upload the site on my server.


Reproducible: Always

Steps to Reproduce:
1. See the file pb.html and the image files
2. Open locally with Firefox : all images displayed
3. Upload on the remote site
4. Open url with firefox : one image is not displayed
5. Open same url with Internet Explorer : all images are displayed
Actual Results:  
One of the images is not displayed

Expected Results:  
All images should be displayed independently of their names.

Renaming the image file allows it to be displayed (and modifying the html accordingly of course). The same bug "works" with any image contents.

Can't upload a file, here is the html code :
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<html lang="fr-fr">
<head>
  <meta content="text/html; charset=ISO-8859-1" http-equiv="content-type">
  
</head>
<body id="events">
    
    <p>lien et image invisibles ???</p>
    
    <p> aff-stg-2000-thumb.jpg => visible
    <br>
       <img src="aff-stg-2000-thumb.jpg">
    </p>
    <p> images/aff-stg-2000-thumb.jpg => invisible

    <br>
        <img src="images/aff-stg-2000-thumb.jpg" width="100" height="75">
    </p>
    <p> images/affstg-2000-thumb.jpg => visible
    <br>
        <img src="images/affstg-2000-thumb.jpg">
    </p>
    <p> images/affstg2000-thumb.jpg => visible
    <br>
        <img src="images/affstg2000-thumb.jpg">
    </p>
    <p> images/tst-stg-2000-thumb.jpg => visible
    <br>
        <img src="images/tst-stg-2000-thumb.jpg">
    </p>

</body>
</html>
Can you please point to a site showing the problem?
All the images are visible for me 

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 (.NET CLR 3.5.30729)

Have you tried safe-mode and/or a new profile?

Comment 4

7 years ago
Did you try to remove the ' width="100" height="75"' part from the img tag of the only image that remains invisible to you?

Alternatively, you can read http://kb.mozillazine.org/Websites_look_wrong, it may be helpful.
Yeah, I see all the images as well...

Comment 6

7 years ago
I recently had the same problem. My solution was to comment out the following line in my .mozconfig:

ac_add_options --enable-optimize="-pipe -O3"

Hope it helps.
It looks like a problem with the configuration and not a bug. Please re-open with more information if the problem persist.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.