Replaying keyboard macros causes unexpected behaviour.

VERIFIED WORKSFORME

Status

P3
normal
VERIFIED WORKSFORME
18 years ago
14 years ago

People

(Reporter: steve.g.graham, Assigned: vishy)

Tracking

({crash})

Trunk
x86
Windows 95
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla on Windows95
BuildID:    2000101014

Using the windows tool WXKBD (see http://www.szp-software.com/) to replay 
keystrokes causes Mozilla to open new windows; start help; open the print 
dialog; and sometimes to crash.

Reproducible: Always
Steps to Reproduce:
1.install WXKBD
2.program a key (e.g. CTRL-Q) with a string (e.g. "hello")
3.hit your key in a form field or in the browser location field

Actual Results:  Open File dialog opens
Open Location dialog opens (twice)
History Pane opens
Composer opens

CRASH!:
MOZILLA caused an invalid page fault in
module JS3250.DLL at 0157:60b2be7a.
Registers:
EAX=01a84540 CS=0157 EIP=60b2be7a EFLGS=00010283
EBX=fa8b3e10 SS=015f ESP=0068e028 EBP=0068e158
ECX=06a11500 DS=015f ESI=012c5314 FS=18b7
EDX=01a84540 ES=015f EDI=01a84578 GS=0000
Bytes at CS:EIP:
89 3b 8b 40 0c 3b 85 78 ff ff ff 74 11 50 89 85 
Stack dump:
00000000 008693a0 012c5308 60b1f91b 008693a0 0068e1dc 01a84760 00000000 008693a0 
00000000 0068e08c 00000008 0000003c bff79fc3 816449d8 0000003c 

Expected Results:  Entered the text "hello" into the location field.

All other windows apps I've tried work as expected with the keyboard macro 
utility, including Netscape 4.75.

Are you doing something non-standard in your Windows keyboard-handling? Or are 
you obeying the rules but WXKBD isn't?
[Not a UI design issue, --> XP Apps]
Assignee: hangas → don
Component: User Interface: Design Feedback → XP Apps
Keywords: crash
QA Contact: mpt → sairuh

Comment 2

18 years ago
don is no longer @netscape.com 
reassigning to vishy
Assignee: don → vishy

Comment 3

18 years ago
Reporter is this still a problem in the altest nightlies?

Comment 4

18 years ago
Marking WORKSFORME due to lack of response and the fact that the build the
reporter used is so old. Reopen if its still a problem in the latest nightlies.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
mass verification of WorksForMe bugs: to find all bugspam pertaining to this,
set your search string to "IfItWorksForSlappyTheSquirrelThenItWFM".

if you think this particular bug is *still* an open issue, please make sure of
the following before reopening:

a. that it's still a problem with ***recent trunk builds*** on the all
appropriate platform[s]

b. provide clear steps to reproduce (unless a good test case is already in the
bug report), making sure it pertains to the original problem (avoid morphing as
much as possible :)
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.