Closed Bug 621151 Opened 9 years ago Closed 9 years ago

Crash in [@ mozilla::WebGLContext::MakeContextCurrent() ] zooming out of WebGL context and restoring zoom level

Categories

(Core :: Canvas: WebGL, defect, critical)

x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: Tobbi, Unassigned)

References

()

Details

(Keywords: crash)

Crash Data

When zooming into a WebGL context (best reproducible with the http://videos.mozilla.org/serv/mozhacks/flight-of-the-navigator/ ) and out, 
you get the following crash:
http://crash-stats.mozilla.com/report/index/bp-cc57d63a-8b1e-46aa-b3bc-0731f2101223

This is reproducible on trunk.

Graphics
Adapter Description Intel(R) HD Graphics
Vendor ID 8086 
Device ID 0046
Adapter RAM Unknown
Adapter Driver sigdumdx32 igd10umd32
Driver Version 8.15.10.2202 
Driver Date 8-25-2010 
Direct2D Enabled true
DirectWrite Enabled true
WebGL Renderer Intel -- Intel(R) HD Graphics -- 2.1.0 - Build 8.15.10.2202
GPU Accelerated Windows 1/1 Direct3D 10
Summary: Crash in [@ mozilla::WebGLContext::MakeContextCurrent()] zooming out of WebGL context and restoring zoom level → Crash in [@ mozilla::WebGLContext::MakeContextCurrent() ] zooming out of WebGL context and restoring zoom level
Signature mozilla::WebGLContext::MakeContextCurrent() 
UUID cc57d63a-8b1e-46aa-b3bc-0731f2101223 
Time 2010-12-23 05:50:08.483835 
Uptime 17483 
Last Crash 140939 seconds (1.6 days) before submission 
Install Age 51642 seconds (14.3 hours) since version was first installed. 
Product Firefox 
Version 4.0b9pre 
Build ID 20101222030351 
Branch 2.0 
OS Windows NT 
OS Version 6.1.7600 
CPU x86 
CPU Info GenuineIntel family 6 model 37 stepping 2 
Crash Reason EXCEPTION_ACCESS_VIOLATION_READ 
Crash Address 0x0 
User Comments 
App Notes AdapterVendorID: 8086, AdapterDeviceID: 0046

Processor Notes 
EMCheckCompatibility False 
Crashing ThreadFrame Module Signature [Expand] Source 
0 xul.dll mozilla::WebGLContext::MakeContextCurrent content/canvas/src/WebGLContext.h:441 
1 xul.dll mozilla::WebGLContext::ClearColor content/canvas/src/WebGLContextGL.cpp:575 
2 xul.dll nsIDOMWebGLRenderingContext_ClearColor obj-firefox/js/src/xpconnect/src/dom_quickstubs.cpp:27153 
3 @0x3e9eea0 
4 mozjs.dll js::mjit::EnterMethodJIT js/src/methodjit/MethodJIT.cpp:745 
5 mozjs.dll CheckStackAndEnterMethodJIT js/src/methodjit/MethodJIT.cpp:770 
6 mozjs.dll js::mjit::JaegerShot js/src/methodjit/MethodJIT.cpp:787 
7 mozjs.dll js::RunScript js/src/jsinterp.cpp:654 
8 mozjs.dll js::Invoke js/src/jsinterp.cpp:737 
9 mozjs.dll js::ExternalInvoke js/src/jsinterp.cpp:858 
10 mozjs.dll JS_CallFunctionValue js/src/jsapi.cpp:5028 
11 xul.dll nsJSContext::CallEventHandler dom/base/nsJSEnvironment.cpp:2177 
12 xul.dll nsGlobalWindow::RunTimeout dom/base/nsGlobalWindow.cpp:9012 
13 xul.dll nsGlobalWindow::TimerCallback dom/base/nsGlobalWindow.cpp:9357 
14 xul.dll nsTimerImpl::Fire xpcom/threads/nsTimerImpl.cpp:425 
15 xul.dll nsTimerEvent::Run xpcom/threads/nsTimerImpl.cpp:517 
16 xul.dll nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:626 
17 xul.dll mozilla::ipc::MessagePump::Run ipc/glue/MessagePump.cpp:110 
18 xul.dll xul.dll@0xb199ab 
19 xul.dll MessageLoop::RunHandler ipc/chromium/src/base/message_loop.cc:202 
20 mozcrt19.dll _VEC_memzero 
21 xul.dll xul.dll@0x357b2d 
22 firefox.exe firefox.exe@0x1bb7 
23 ntdll.dll LdrpGetShimEngineInterface 
24 ntdll.dll _RtlUserThreadStart 
25 firefox.exe firefox.exe@0x186f 
26 firefox.exe firefox.exe@0x186f
Can you install the DirectX Redist package and try again?  We'll be blocklisting non-ANGLE renderers on Intel soon, and to get ANGLE you need to have the redist installed -- grab it from http://www.microsoft.com/downloads/en/details.aspx?FamilyID=2da43d38-db71-4c1b-bc6a-9b6652cd92a3&displaylang=en .

You'll see the WebGL Renderer change in about:support when it's set up.
Okay, no crash anymore with an updated DirectX and Angle enabled.

Marking as worksforme.

I hope we display a user-friendly message when blocklisting? I might not be the only one who ran into this.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ mozilla::WebGLContext::MakeContextCurrent() ]
You need to log in before you can comment on or make changes to this bug.