Persona is no longer an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 621207 - Tabs should not change size when clicking a tab close button
: Tabs should not change size when clicking a tab close button
Status: RESOLVED DUPLICATE of bug 465086
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86_64 Linux
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
Depends on:
  Show dependency treegraph
Reported: 2010-12-23 12:50 PST by Ryan
Modified: 2010-12-23 12:57 PST (History)
1 user (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Description Ryan 2010-12-23 12:50:44 PST
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b9pre) Gecko/20101223 Firefox-4.0/4.0b9pre
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b9pre) Gecko/20101223 Firefox-4.0/4.0b9pre

When you have many tabs open and you click on the close button to close one of them, all the tabs get slightly larger to fill up the tab bar again. This is bad, because the tabs are shifting around right under the user's mouse. The tabs should not change size until the mouse leaves the tab bar. This makes it easier to close several tabs in a row.

Tabs should never change their dimensions while the mouse is inside the tab bar.

The only possible exception is closing the rightmost tab, in which case expanding the other tabs to fill probably makes sense.

Reproducible: Always

Steps to Reproduce:
1. Open many tabs.
2. Click any tab's close tab button except the last.
Actual Results:  
The tabs resize to fill in the gap left by the deleted tab, making it impossible to predict where the other tabs will be after closing the tab.

Expected Results:  
All the tabs to the right of the closed tab should have shifted one tab-width to the left, without any tabs changing size, thus leaving a space as wide as the closed tab on the right end of the tab bar. Once the mouse leaves the tab bar entirely, the tabs should expand to fill the space.
Comment 1 Ryan 2010-12-23 12:53:09 PST
This delayed resizing feature is present in Chrome. Here is an article with lots of pictures that demonstrate why this feature is awesome:
Comment 2 Kevin Brosnan 2010-12-23 12:57:05 PST
Known issue. May make it into Firefox 4.

*** This bug has been marked as a duplicate of bug 465086 ***

Note You need to log in before you can comment on or make changes to this bug.