If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Too many "-" characters in HTML comment

RESOLVED DUPLICATE of bug 214476

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 214476
7 years ago
7 years ago

People

(Reporter: cjgensheimer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/534.10 (KHTML, like Gecko) Chrome/8.0.552.224 Safari/534.10
Build Identifier: 3.6.1.3

I was developing a web site and added the comment: 

"    <!-- ------------------------------------------------------------------------------ -->" to separate a few blocks of code. This rendered in IE and Chrome but not FF. Changing the "-" characters to "*" characters fixed it. Example:

    <!-- ************************************************************************************** -->



Reproducible: Always

Steps to Reproduce:
1. Explained in "Details Section"
2.
3.
Actual Results:  
Explained in "Details Section"

Expected Results:  
Explained in "Details Section"

Explained in "Details Section"

Comment 1

7 years ago
This was the correct way to do it in html4 but as you noticed no other browser implemented the specification properly. This changed in html5 and Firefox 4 implements that so once that comes out this will no longer be an issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 214476
You need to log in before you can comment on or make changes to this bug.