Corrupted rendering in Flight of the Navigator with OpenGL (webgl.prefer_gl true)

RESOLVED WORKSFORME

Status

()

Core
Canvas: WebGL
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: JK, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8) Gecko/20100101 Firefox/4.0b8
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20101223 Firefox/4.0b9pre

Corrupted rendering in Flight of the Navigator with OpenGL rendering. Especially noticeable in the video screens (roughly from 1.54).

Reproducible: Always

Steps to Reproduce:
1. Go to about:config
2. Make a pref: webgl.prefer_gl = true
3. Play the Flight of the Navigator demo



Radeon HD 4650, Catalyst 10.12 driver (the version with the new control panel).
(Reporter)

Updated

7 years ago
Component: General → Canvas: WebGL
Version: unspecified → Trunk
(Reporter)

Comment 1

7 years ago
Created attachment 499647 [details]
picture 1
(Reporter)

Comment 2

7 years ago
Created attachment 499648 [details]
picture 2
(Reporter)

Updated

7 years ago
Summary: Corrupted rendering in Flight of the Navigator with OpenGL rendering → Corrupted rendering in Flight of the Navigator with OpenGL (webgl.prefer_gl true)

Comment 3

7 years ago
Confirmed on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20101224 Firefox/4.0b9pre ID:20101224030347

Graphics:      
Adapter Description : ATI Radeon HD 4300/4500 Series
Vendor ID : 1002
Device ID : 954f
Adapter RAM : 512
Adapter Drivers : aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64
atiumdag atidxx32 atiumdva atiumd6a atitmm64
Driver Version : 8.791.0.0
Driver Date : 
Direct2D Enabled : true
DirectWrite Enabled : true
WebGL Renderer : ATI Technologies Inc. -- ATI Radeon HD 4300/4500 Series     -- 3.3.10317 Compatibility Profile Context
GPU Accelerated Windows : 1/1 Direct3D 10


*It seems to be no problem on Google Chrome8.0.552.224
Same here with on WinXP using
Driver Version: 8.593.100.0
Driver Date: 2-10-2010
WebGL Renderer: ATI Technologies Inc. -- Radeon X1950 Pro -- 2.1.8545 Release

Latest DirectX 9 Update is applied.
(Reporter)

Comment 5

7 years ago
(In reply to comment #3)
> *It seems to be no problem on Google Chrome8.0.552.224

Is there a setting to disable ANGLE in Chrome?

Comment 6

7 years ago
(In reply to comment #5)
> (In reply to comment #3)
> > *It seems to be no problem on Google Chrome8.0.552.224
> 
> Is there a setting to disable ANGLE in Chrome?
I do not know how to disable it.

Comment 7

7 years ago
[CONFIRMED a problem: Black Screen !]
Adapter DescriptionATI Mobility Radeon HD 3450
Vendor ID1002
Device ID95c4
Adapter RAM256
Adapter Drivers atiumdag atidxx32 atidxx64 atiumdva atiumd64 atiumd6a atitmm64
Driver Version 8.632.3.0
Driver Date 7-22-2009
Direct2D Enabled true
DirectWrite Enabled true
WebGL RendererATI Technologies Inc. -- ATI Mobility Radeon HD 3450 -- 2.1.8787
GPU Accelerated Windows1/1 Direct3D 10

This happens also in google body browser "http://bodybrowser.googlelabs.com/body.html#" with webgl.prefer_gl = true !

Comment 8

7 years ago
Created attachment 499714 [details]
screenshot with Mozilla/5.0 (Windows NT 6.1; rv:2.0b9pre) Gecko/20101224 Firefox/4.0b9pre ID:20101224030347

Chrome dose not have this problem !
(Reporter)

Comment 9

7 years ago
(In reply to comment #7)

> This happens also in google body browser
> "http://bodybrowser.googlelabs.com/body.html#" with webgl.prefer_gl = true !

> Driver Date 7-22-2009

The Body Browser works for me - I think your problem is due to an outdated driver. AMD releases graphics drivers every month.

Comment 10

7 years ago
I can't install the latest drivers for my laptop, hp dose not offer them and I can't use the ones in the AMD's website. 

If it is the drivers, why Chrome dose not have this problem?

I think FF4b7 dose not have this problem on my machine. (I'll check and reply)

Comment 11

7 years ago
(In reply to comment #3)
> Confirmed on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20101224
> Firefox/4.0b9pre ID:20101224030347
> 
> Graphics:      
> Adapter Description : ATI Radeon HD 4300/4500 Series
> Vendor ID : 1002
> Device ID : 954f
> Adapter RAM : 512
> Adapter Drivers : aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64
> atiumdag atidxx32 atiumdva atiumd6a atitmm64
> Driver Version : 8.791.0.0
> Driver Date : 
> Direct2D Enabled : true
> DirectWrite Enabled : true
> WebGL Renderer : ATI Technologies Inc. -- ATI Radeon HD 4300/4500 Series     --
> 3.3.10317 Compatibility Profile Context
> GPU Accelerated Windows : 1/1 Direct3D 10
> 
> 
> *It seems to be no problem on Google Chrome8.0.552.224

In addition to the above.
This problem does not happen on Ubuntu10.04.1 installed on same hardware and default setting without webgl.enabled_for_all_sites to true.
Mozilla/5.0 (X11; Linux i686; rv:2.0b9pre) Gecko/20101225 Firefox/4.0b9pre ID:20101225030337
(In reply to comment #10)
> I can't install the latest drivers for my laptop, hp dose not offer them and I
> can't use the ones in the AMD's website. 
> 
> If it is the drivers, why Chrome dose not have this problem?

Chrome's and Firefox's implementations of WebGL are different in sufficiently many ways, that one can hit a driver bug that the other doesn't.

This bug is certainly a driver bug.

> 
> I think FF4b7 dose not have this problem on my machine. (I'll check and reply)

Please do.

Comment 13

7 years ago
(In reply to comment #12)
> Please do.

Same problem in FF4b7.

I have updated the driver and the problem is gone :)


(In reply to comment #10)
> I can't install the latest drivers for my laptop, hp dose not offer them and I
> can't use the ones in the AMD's website. 
> 
> If it is the drivers, why Chrome dose not have this problem?

Now you can update the driver for your laptop directly from www.AMD.com :D

(Toshiba, Sony and Panasonic are excluded)
Since this is only a bad-rendering bug, and it won't happen with default preferences (since by default we use ANGLE for rendering on Windows) and is fixed anyway in current driver (comment 13), closing this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME

Comment 15

7 years ago
Why close the bug?
It happens on clean profile and latest driver.

Comment 16

7 years ago
  Graphics

        Adapter Description
        ATI Radeon HD 4300/4500 Series

        Vendor ID
        1002

        Device ID
        954f

        Adapter RAM
        512

        Adapter Drivers
        aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64

        Driver Version
        8.801.0.0

        Driver Date

        Direct2D Enabled
        true

        DirectWrite Enabled
        true

        WebGL Renderer
        ATI Technologies Inc. -- ATI Radeon HD 4300/4500 Series        -- 3.3.10362 Compatibility Profile Context

      GPU Accelerated Windows
      1/1 Direct3D 10
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WORKSFORME → ---
(In reply to comment #15)
> Why close the bug?
> It happens on clean profile and latest driver.

The bug title says "webgl.prefer_gl true". This is incompatible with saying "clean profile". Which one is true?

Comment 18

7 years ago
I mean "clean profile"
So the bug title, saying "webgl.prefer_gl true", is wrong? If this bug happens without this preference set, the title needs to be edited.

Comment 20

7 years ago
(In reply to comment #19)
> So the bug title, saying "webgl.prefer_gl true", is wrong? If this bug happens
> without this preference set, the title needs to be edited.

OK  I'm not a original reporter. And I misread the title.
And I revert the status of bug.

I filed a new Bug 622094.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → WORKSFORME
I just thought about the fact that we still are relying on the user to install the DirectX runtime (the plan is to no longer rely on that in final FF4).

So the confusion could easily come from there. In the absence of DirectX runtime, it falls back to opengl.

Please try with the DirectX runtime installed.
(Reporter)

Comment 22

7 years ago
(In reply to comment #19)
> So the bug title, saying "webgl.prefer_gl true", is wrong? If this bug happens
> without this preference set, the title needs to be edited.

For me, this does not happen with ANGLE. Only with GL.
You need to log in before you can comment on or make changes to this bug.