Going back when a tab-modal prompt is active causes a compartment mismatch

RESOLVED DUPLICATE of bug 614131

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 614131
8 years ago
8 years ago

People

(Reporter: khuey, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Using the testcase for Bug 619644, clicking back while the prompt is visible will assert on a compartment mismatch.
blocking2.0: --- → ?
Component: General → DOM
Product: Toolkit → Core
QA Contact: general → general
Component: DOM → XPConnect
QA Contact: general → xpconnect
Isn't this the normal thing with a compartment changing while script is running on it?  I thought the js folks were looking into that sort of thing.
Assignee: nobody → general
Component: XPConnect → JavaScript Engine
QA Contact: xpconnect → general
Same problem as bug 614131, navigation from within a nested event loop inside a script causes a compartment mismatch "later". Good to know of another instance in which this can occur!
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 614131
blocking2.0: ? → ---
You need to log in before you can comment on or make changes to this bug.