When a word is double-clicked not only the word is selected but also a space is selected

VERIFIED DUPLICATE of bug 423859

Status

()

Core
General
--
major
VERIFIED DUPLICATE of bug 423859
7 years ago
7 years ago

People

(Reporter: Ilhan Y., Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b9pre) Gecko/20101224 Firefox/4.0b9pre
Build Identifier: latest nightly Minefield on december 24 (time zone: 2)

When a word is double-clicked not only the word is selected but also a space is selected

Reproducible: Always

Steps to Reproduce:
1. Double click to this word.
Actual Results:  
"this " is selected

Expected Results:  
only "this" should be selected

every time i have to delete the space, very unnecessary and boring and thus not user-friendly
(Reporter)

Updated

7 years ago
Severity: normal → major

Comment 1

7 years ago
not a bug.

set layout.word_select.eat_space_to_next_word to false.
(Reporter)

Comment 2

7 years ago
why not a bug?
Because apparently this is expected behavior on Windows.  If you look at http://mxr.mozilla.org/mozilla-central/source/modules/libpref/src/init/all.js the preference is set to false on all operating systems by default _except_ Windows and OS/2.  Last I checked, this was the default Windows double-click word selection behavior.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

7 years ago
ok thanks, i found this https://bugzilla.mozilla.org/show_bug.cgi?id=423859
Status: RESOLVED → VERIFIED
Resolution: INVALID → DUPLICATE
Duplicate of bug: 423859
You need to log in before you can comment on or make changes to this bug.