Flash Content - Black Text on White Background NOT Displayed

RESOLVED DUPLICATE of bug 611698

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 611698
8 years ago
8 years ago

People

(Reporter: Chris B., Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20101224 Firefox/4.0b9pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20101224 Firefox/4.0b9pre

Black text on a white background for Flash content does NOT display properly with the latest Minefield.  The problem is evident on the above website.

A screenshot comparison against Internet Explorer 9 Beta shows IE to render the page correctly.

I will report in a couple minutes wheter or not the bug appears in 3.6.X.

Reproducible: Always

Steps to Reproduce:
1. Go to the above website.
2. Cannot read Flash content where there is Black Text on a white background.
3. If you highlight the Flash area in Firefox, it is reverse of what it is supposed to be.  Supposed to be Black Text on White, like with IE.  When highlighting in Firefox, you get White Text on Black, but it is not visible without highlighting.
Actual Results:  
Black Text on Black Background.

Expected Results:  
Black Text on White Background.
(Reporter)

Comment 1

8 years ago
Created attachment 499666 [details]
Flash Rendering Bug
(Reporter)

Comment 2

8 years ago
The site loads correctly in 3.6.13, as shown in the second Attachment (Flash Rendering - Correct in 3.6.13).
(Reporter)

Comment 3

8 years ago
Created attachment 499667 [details]
Flash Rendering - Correct in 3.6.13

Comment 4

8 years ago
Works;
http://hg.mozilla.org/mozilla-central/rev/212a391d3b79
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101109
Firefox/4.0b8pre ID:20101110052514
fails:
http://hg.mozilla.org/mozilla-central/rev/bdbef533364f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101109
Firefox/4.0b8pre ID:20101110081923
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=212a391d3b79&tochange=bdbef533364f
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 611698
You need to log in before you can comment on or make changes to this bug.