yahoo.com - Yahoo! Companion doesn't support Moz/N6

RESOLVED FIXED in Future

Status

Tech Evangelism Graveyard
English US
P1
minor
RESOLVED FIXED
18 years ago
3 years ago

People

(Reporter: ekrock's old account (dead), Unassigned)

Tracking

({top100, top500})

unspecified
Future
x86
All
top100, top500

Details

(Whiteboard: [smartupdate] [author] [not-responsive] [bug248549notfixed], efu, URL)

(Reporter)

Description

18 years ago
User report. I think the YC depends on lots of Nav4-specific functionality and
needs to be upgraded to support Netscape 6.

Operating System: 	Win98
Language: 		English
Issue Summary: 		I could not add Yahoo! Companion to my browser bar
Component: 		PageLayout
Doing What: 		Other  Customizing Homepage as existed in Netscape 4.5
Severity: 		Other  message is that 6.0 does not support this addition
Can Reproduce: 		Always
Try this URL: 		http://
Issue Detail:
I have Yahoo! Companion on my Netscape 4.5 browser
page.  I check it several times a day.  I cannot
add this feature to 6.0 and the message is that
6.0 will not support the function.  What is the
problem. Is this a defect in 6.0 or can I make
adjustments within the browser?  If so, how?

Comment 1

17 years ago
Reassigning evangelism bugs to bclary@netscape.com.
Assignee: evangelism → bclary

Comment 2

17 years ago
Added url, but seems this is nead in ie6 too.
Severity: normal → minor

Updated

17 years ago
Summary: Yahoo! Companion doesn't support Moz/N6 → yahoo.com - Yahoo! Companion doesn't support Moz/N6

Comment 3

17 years ago
updated url.

I get the same message in NN 4.77 as on Mozilla/NS6.1 on Win2k

Sorry, it doesn't appear that your system will support the Yahoo!        
Companion. Please refer to the "What Do I Need" section below for system
requirements.
Windows 95 / NT / 98 Operating System
Netscape Navigator (4.0 and above but below 6.0) or;
Microsoft Internet Explorer (4.0 and above but below 6.0)

Contacted
          

Comment 4

17 years ago
Ok, afaik, there is no way to programmatically change the personal tool bar from
a script on the web. The user has to navigate to a page, then drag the URL
grippy from the URL bar onto the personal tool bar. Is that correct?

but when I drag the URL grippy onto the personal tool bar I get (Mozilla/5.0
(Windows; U; Windows NT 5.0; en-US; rv:0.9.2) Gecko/20010726):

Error: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIBookmarksService.insertBookmarkInFolder]" 
nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://navigator/content/navigatorDD.js :: anonymous :: line 345"  data: no]
Source File: chrome://global/content/nsDragAndDrop.js
Line: 105
What is happening with this?

Comment 5

17 years ago
Ok, my problem was probably bug 88711

Comment 6

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 7

17 years ago
follow up with these sites by 0.9.5
Target Milestone: --- → mozilla0.9.5

Updated

17 years ago
Keywords: top100

Updated

17 years ago
Priority: P3 → P1

Comment 8

17 years ago
tried with 4.76, smartupdate was used
Whiteboard: [smartupdate]

Comment 9

17 years ago
-> 0.9.6, need to follow up on these asap
Target Milestone: mozilla0.9.5 → mozilla0.9.6
going to be hard to get this to work
Status: ASSIGNED → NEW
Target Milestone: Nov → ---

Comment 11

17 years ago
doron, isn't there a xul/xbl way to get it to work for them?
Yes there is, at least much of the functionality.  Since I don't have any idea
how the toolbar really works, the main issue will be to get xul/js to work with
their existing infrastructure, since a lot of the toolbar depends on what seems
to be stored info on yahoo's servers.
authors
Component: US General → Authors
OS: Windows 98 → All
Whiteboard: [smartupdate] → [smartupdate][aok[

Updated

17 years ago
Blocks: 121228

Updated

17 years ago
Keywords: evang500
Whiteboard: [smartupdate][aok[ → [smartupdate]

Comment 14

17 years ago
See http://googlebar.mozdev.org/

It is a project to recreate an emulation of Google's toolbar in XUL/JS and there
might be some related code between the Google toolbar and Yahoo! Companion since
they have a similar intent.
(just a guess)

Comment 15

17 years ago
I wouldn't spend time looking at this...not fixing in the near future, if at all.

Comment 16

16 years ago
Hi

Now that Moz is into 1.0, can we not give Yahoo! a friendly nudge to update
their toolbar to work with Mozilla and the upcoming NS7?

I imagine a fair few end-users will be disappointed if NS7 doesnt support the
Yahoo toolbar. I have friends who dont use Moz because all their bookmarks are
stored in their Yahoo Toolbar and so it is a pain to switch

An additional point - I know there are / have been compatibility issues between
various aspects of Yahoo (searching for Yahoo in bugzilla throws up 40 bugs) and
Mozilla. Given that Yahoo is such a visable site, shouldnt there be someone on
the Moz / NS team to act as an advocate to comunicate, push and work with Yahoo
on these issues? Just a suggestion.

dave 
if we had xpuninstall

Comment 18

16 years ago
Netscape 4.8 will install the Yahoo! Companion, I agree with p4peter's guess,
could we take the idea of http://googlebar.mozdev.org/ 
What about comparing the source of googlebar to the source of the plugin that
compantion is/uses, the files installed on my pc via netscape 4.8 for companion
were %netscape install
dir%\netscapcommunicator\program\plugins\npycomp1,2,0,8.dll AND
..plugins\YahooCompanionJavaLC.class, if I am going down the completely wrong
path to trying to get a fix for this please let me know.
I don't know if googlebar.mozdev.org is the correct way to go, because if yahoo!
were to go that way then they would have to get two different companion's, one
for the latest versions of netscape and mozilla, and then keep the old one for
IE and netscape. However, if they rebuilt, or revised it to support Netscape 4.x
and up (including mozilla), IE 4.0 and up, and Opera, then that would be a more
rounded and better way to go about it.

          Thats my opinion, thanks for letting me voice it.
                        -Jason Anderson
what´s the current status of this? Are we getting xpuninstall? Has Yahoo made 
any comments on their attentions to work with Mozilla?

Comment 20

15 years ago
tech evang june 2003 reorg
Assignee: bc → english-us
Component: Authors → English US
QA Contact: zach → english-us
Whiteboard: [smartupdate] → [smartupdate] [author]

Comment 21

15 years ago
It looks like someone on MozDev hooked into this:

http://companion.mozdev.org/

Does this mean that we should mark this as WONTFIX?

-M

Comment 22

15 years ago
wontfix has been deprecated. use status whiteboard of not-responsive. See
http://www.mozilla.org/projects/tech-evangelism/site/procedures.html
Whiteboard: [smartupdate] [author] → [smartupdate] [author] [not-responsive]
Target Milestone: --- → Future

Updated

14 years ago
Whiteboard: [smartupdate] [author] [not-responsive] → [smartupdate] [author] [not-responsive] [bug248549notfixed]

Comment 23

14 years ago
The toolbar at http://companion.mozdev.org/ now implements most of the primary
functions of the Yahoo! Companion toolbar.  The priority of this bug can
probably be lowered to P2 ("Major site, minor problem").  

I would still keep this bug open.   The Yahoo! Companion toolbar still has some
features that the Mozdev toolbar doesn't support.  It would also be nice to have
a Yahoo! toolbar that Yahoo! officially supported on Mozilla.

Updated

14 years ago
Keywords: top500
evangelism bug triage - Need to decide what to do concerning this bug.
Whiteboard: [smartupdate] [author] [not-responsive] [bug248549notfixed] → [smartupdate] [author] [not-responsive] [bug248549notfixed], efu
I understand yahoo is working on a firefox toolbar.  Also, yahoo now links to
http://companion.mozdev.org/.

Comment 26

13 years ago
Seeing as the Yahoo! toolbar started a beta for Yahoo! toolbar back in February
and there has now been a second public beta I think that this bug can officially
be closed unless there are any objections.

Comment 27

13 years ago
(In reply to comment #26)
> Seeing as the Yahoo! toolbar started a beta for Yahoo! toolbar back in February
> and there has now been a second public beta I think that this bug can officially
> be closed unless there are any objections.

agreed. 
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.