Search button is opening the dmoz.org powered Netscape Search, instead of the multiple vendor(Lycos, Looksmart, Google, HotBot, etc) one.

VERIFIED INVALID

Status

P3
normal
VERIFIED INVALID
18 years ago
11 years ago

People

(Reporter: stephend, Assigned: matt)

Tracking

Trunk
mozilla0.9
All
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Build ID 2000120604.  Windows NT, commercial build.

Steps to repro:
1. Click Search

Expected Results:
Netscape should search using a page like this:
http://home.netscape.com/escapes/search/ntsrchnd-6.html

Actual Results:
http://search.netscape.com/cgi-bin/search?search=
Note: this behavior is *only* on NT, Mac and Linux are fine.
Upgrading from trivial to normal, per ad revenue issues.
Severity: trivial → normal
Keywords: netcenter
This is FIXED in 2000121204.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
This bug occurs on Linux when I have the sidebar minimized, with/without the
sidebar on Mac and with/without it on Windows.  All commercial builds, todays.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
This bug changes so often, it's making me wonder if there's a redirector
involved here within Netcenter and it happens so fast the user doesn't notice?
we need to look into this. 
Target Milestone: --- → mozilla0.9

Comment 9

18 years ago
I just repro'd this with a fresh (2001011708) Linux build.

What's supposed to happen:
When you haven't typed anything in the url bar or it's empty ('clean') and you click the
'Search' button you are supposed to be taken to the rotating netscape search page or
one you have selected in your Smart Browsing prefs.

What's really happening:
We instead see the url bar as 'dirty' and execute a search on what the user has typed in
the url bar. Of course, in this case that's nothing and we end up doing a search on what's
between these quotes: ""

I believe this should be a higher priority and a Beta stopper
Hardware: PC → All
Since I believe Mozilla users could care less about this, I've moved it to
Bugscape.  The URL follows: http://bugscape.netscape.com/show_bug.cgi?id=3856

Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → INVALID
VERIFIED.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.