Fennec-Qt crashes on close

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
8 years ago
2 years ago

People

(Reporter: naginenis, Unassigned)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
(gdb) bt
#0  NS_StackWalk (aCallback=0x1049500 <PrintStackFrame>, aSkipFrames=2, aClosure=0x0)
    at /home/user/mozilla-central/xpcom/base/nsStackWalk.cpp:1488
#1  0x0104946e in ah_crap_handler (signum=11) at /home/user/mozilla-central/toolkit/xre/nsSigHandlers.cpp:125
#2  0x0104bd0b in nsProfileLock::FatalSignalHandler (signo=11, info=0xbfe11a6c, context=0xbfe11aec) at nsProfileLock.cpp:226
#3  <signal handler called>
#4  0x06d7e174 in QListData::isEmpty (this=0xb3495228, mouseEvent=0xbfe122fc)
    at ../../include/QtCore/../../src/corelib/tools/qlist.h:91
#5  QList<QGraphicsItem*>::isEmpty (this=0xb3495228, mouseEvent=0xbfe122fc)
    at ../../include/QtCore/../../src/corelib/tools/qlist.h:134
#6  QGraphicsScene::mouseReleaseEvent (this=0xb3495228, mouseEvent=0xbfe122fc) at graphicsview/qgraphicsscene.cpp:4062
#7  0x06d8d6dc in QGraphicsScene::event (this=0xb3495228, event=0xbfe122fc) at graphicsview/qgraphicsscene.cpp:3398
#8  0x066e14dc in QApplicationPrivate::notify_helper (this=0xb75260c0, receiver=0xb3495228, e=0xbfe122fc)
    at kernel/qapplication.cpp:4300
#9  0x066e805e in QApplication::notify (this=0xb75170e0, receiver=0xb3495228, e=0xbfe122fc) at kernel/qapplication.cpp:3704
#10 0x00c3ea3b in QCoreApplication::notifyInternal (this=0xb75170e0, receiver=0xb3495228, event=0xbfe122fc)
    at kernel/qcoreapplication.cpp:704
#11 0x066e22be in QCoreApplication::sendSpontaneousEvent (receiver=0xb3495228, event=0xbfe122fc)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#12 qt_sendSpontaneousEvent (receiver=0xb3495228, event=0xbfe122fc) at kernel/qapplication.cpp:5279
#13 0x06dadcd5 in QGraphicsView::mouseReleaseEvent (this=0xb34c0a40, event=0xbfe12a10)
    at graphicsview/qgraphicsview.cpp:3259
#14 0x0673f7f8 in QWidget::event (this=0xb34c0a40, event=0xbfe12a10) at kernel/qwidget.cpp:7998
#15 0x06b3bfd3 in QFrame::event (this=0xb34c0a40, e=0xbfe12a10) at widgets/qframe.cpp:557
#16 0x06bd6382 in QAbstractScrollArea::viewportEvent (this=0x0, e=0xbfe122fc) at widgets/qabstractscrollarea.cpp:1036
#17 0x06dac06b in QGraphicsView::viewportEvent (this=0xb34c0a40, event=0xbfe12a10) at graphicsview/qgraphicsview.cpp:2787
#18 0x06bd8c65 in QAbstractScrollAreaPrivate::viewportEvent (this=0xb34847a0, o=0xb34c0e00, e=0xbfe12a10)
    at widgets/qabstractscrollarea_p.h:100
#19 QAbstractScrollAreaFilter::eventFilter (this=0xb34847a0, o=0xb34c0e00, e=0xbfe12a10)
    at widgets/qabstractscrollarea_p.h:116
#20 0x00c3dcda in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0xb75260c0, receiver=0xb34c0e00, 
    event=0xbfe12a10) at kernel/qcoreapplication.cpp:819
#21 0x066e14b9 in QApplicationPrivate::notify_helper (this=0xb75260c0, receiver=0xb34c0e00, e=0xbfe12a10)
    at kernel/qapplication.cpp:4296
#22 0x066e89f7 in QApplication::notify (this=0xb75170e0, receiver=0xb34c0e00, e=0xbfe12a10) at kernel/qapplication.cpp:3865
#23 0x00c3ea3b in QCoreApplication::notifyInternal (this=0xb75170e0, receiver=0xb34c0e00, event=0xbfe12a10)
---Type <return> to continue, or q <return> to quit---
    at kernel/qcoreapplication.cpp:704
#24 0x066e7952 in QCoreApplication::sendEvent (receiver=0xb34c0e00, event=0xbfe12a10, alienWidget=0x0, 
    nativeWidget=0xb34c0e00, buttonDown=0x7025058, lastMouseReceiver=..., spontaneous=true)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#25 QApplicationPrivate::sendMouseEvent (receiver=0xb34c0e00, event=0xbfe12a10, alienWidget=0x0, nativeWidget=0xb34c0e00, 
    buttonDown=0x7025058, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:2965
#26 0x06773088 in QETWidget::translateMouseEvent (this=0xb34c0e00, event=0xbfe12f2c) at kernel/qapplication_x11.cpp:4368
#27 0x06772511 in QApplication::x11ProcessEvent (this=0xb75170e0, event=0xbfe12f2c) at kernel/qapplication_x11.cpp:3379
#28 0x067a160a in x11EventSourceDispatch (s=0xb75041f0, callback=0, user_data=0x0)
    at kernel/qguieventdispatcher_glib.cpp:146
#29 0x0509b5e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#30 0x0509f2d8 in ?? () from /lib/libglib-2.0.so.0
#31 0x0509f4b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#32 0x00c6a5d5 in QEventDispatcherGlib::processEvents (this=0xb75170f0, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#33 0x067a1135 in QGuiEventDispatcherGlib::processEvents (this=0xb75170f0, flags=...)
    at kernel/qguieventdispatcher_glib.cpp:204
#34 0x01db3b83 in nsAppShell::ProcessNextNativeEvent (this=0xb5ff98d0, mayWait=1)
    at /home/user/mozilla-central/widget/src/qt/nsAppShell.cpp:113
#35 0x01dca18c in nsBaseAppShell::DoProcessNextNativeEvent (this=0xb5ff98d8, mayWait=1)
    at /home/user/mozilla-central/widget/src/xpwidgets/nsBaseAppShell.cpp:173
#36 0x01dca586 in nsBaseAppShell::OnProcessNextEvent (this=0xb5ff98d8, thr=0xb7277be0, mayWait=0, recursionDepth=0)
    at /home/user/mozilla-central/widget/src/xpwidgets/nsBaseAppShell.cpp:333
#37 0x01e90fa6 in mozilla::dom::ContentParent::OnProcessNextEvent (this=0xb753b3e0, thread=0xb7277be0, mayWait=1, 
    recursionDepth=0) at /home/user/mozilla-central/dom/ipc/ContentParent.cpp:681
#38 0x0202e209 in nsThread::ProcessNextEvent (this=0xb7277be0, mayWait=1, result=0xbfe132ac)
    at /home/user/mozilla-central/xpcom/threads/nsThread.cpp:590
#39 0x01fdbe9c in NS_ProcessNextEvent_P (thread=0x5a5a5a5a, mayWait=1) at nsThreadUtils.cpp:250
#40 0x01eb8886 in mozilla::ipc::MessagePump::Run (this=0xb727ef40, aDelegate=0xb7526fa0)
    at /home/user/mozilla-central/ipc/glue/MessagePump.cpp:134
#41 0x02071c79 in MessageLoop::RunInternal (this=0xb7526fa0)
    at /home/user/mozilla-central/ipc/chromium/src/base/message_loop.cc:219
#42 0x02071d28 in MessageLoop::RunHandler (this=0x5a5a5a5a)
    at /home/user/mozilla-central/ipc/chromium/src/base/message_loop.cc:202
#43 MessageLoop::Run (this=0x5a5a5a5a) at /home/user/mozilla-central/ipc/chromium/src/base/message_loop.cc:176
#44 0x01dca7b2 in nsBaseAppShell::Run (this=0xb5ff98d8)
---Type <return> to continue, or q <return> to quit---
    at /home/user/mozilla-central/widget/src/xpwidgets/nsBaseAppShell.cpp:192
#45 0x01bfeb64 in nsAppStartup::Run (this=0xb41daa60)
    at /home/user/mozilla-central/toolkit/components/startup/src/nsAppStartup.cpp:191
#46 0x01042773 in XRE_main (argc=1, argv=0xbfe139d4, aAppData=0xb7518380)
    at /home/user/mozilla-central/toolkit/xre/nsAppRunner.cpp:3694
#47 0x0804976b in main (argc=1, argv=0xbfe139d4) at /home/user/mozilla-central/mobile/app/nsBrowserApp.cpp:155

Steps to Reproduce:
1. Open Fennec
2. Go to www.google.com
3. Open Site menu and choose 'Share page' option
4. Tap on close 'X' button

Reproducible: always

Comment 1

2 years ago
In bug 1282866, I have removed the QT code from the Firefox tree with the approval of the active peer. That code is not currently maintained by any team.

I have looked through the bugs in the Widget: Qt bugzilla component and I believe all of these are no longer relevant because the Qt code has been removed. If you believe that this bug is still valid, please move it to another more appropriate bugzilla component as you reopen it.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INCOMPLETE
(Assignee)

Updated

2 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.