Double images on monster.com using Fx4, due to broken user-agent sniffing

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
English US
RESOLVED WORKSFORME
7 years ago
3 years ago

People

(Reporter: Chris B., Assigned: Chris B.)

Tracking

Details

(URL)

Attachments

(2 attachments)

(Assignee)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20101226 Firefox/4.0b9pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20101226 Firefox/4.0b9pre

Images on the top of the page are misaligned.  Displays correctly in Internet Explorer 9.  Images are a combination of JPG and GIF.  A screenshot is provided.

Reproducible: Always

Steps to Reproduce:
1. Load above website.
2. Images are misaligned.
3. Images are displayed correctly in Internet Explorer 9.
Actual Results:  
Images are misaligned.

Expected Results:  
No image misalignment.
(Assignee)

Comment 1

7 years ago
Created attachment 499763 [details]
Image Alignment Error
(Assignee)

Comment 2

7 years ago
The site displays correctly with 3.6.13.
(Assignee)

Comment 3

7 years ago
Created attachment 499786 [details]
Image Alignment - Correct Using 3.6.13

Comment 4

7 years ago
Mozilla/5.0 (Windows NT 6.1; rv:2.0b9pre) Gecko/20101226 Firefox/4.0b9pre

Able to reproduce. Few images are not properly aligned in 4.x and 3.6.14pre versions. Works fine in 3.6.13
(Assignee)

Comment 5

7 years ago
I am going to have to find another site soon to reference this bug, as eventually the link above will expire (job posting).
(Assignee)

Comment 6

7 years ago
I just updated the sample website with a new one, since the old job posting expired.
(Assignee)

Comment 7

7 years ago
I also see problems towards the bottom with the bullet points (not sure if it is related to the image alignment error or if a separate bug should be filed).

Comment 8

7 years ago
Confirmed using Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12pre) Gecko/20110220 Firefox/4.0b12pre ID:20110220030351.

Displays fine in 3.6.13 / IE8.

However, page is wonky in Chrome dev 10.x too, looks like the page is poorly designed. eg: If you inspect using Firebug, you can see they have set a background image for the tables as well as inserting an <img> into the first row. This is what causes the doubled up "About ISO" headings.

Suspect this is going to be a tech evang job, but strange it's working in 3.6.13 and not Fx4.
Hardware: x86_64 → x86
Version: unspecified → Trunk

Comment 9

7 years ago
Ah, appears to be bad user agent sniffing, that breaks the site for Firefox 4 as well as Chrome dev.

Works fine with today's nightly (full build ID in comment 8), as long as I set:

general.useragent.override = Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

Moving to tech evang.
Assignee: nobody → english-us
Status: UNCONFIRMED → NEW
Component: General → English US
Ever confirmed: true
Product: Firefox → Tech Evangelism
QA Contact: general → english-us
Summary: Image Alignment Error → Double images on monster.com using Fx4, due to broken user-agent sniffing
Version: Trunk → unspecified

Comment 10

7 years ago
Ed, can you test the following UA string (basically the 4.0 string in comment 8 but without the word "Firefox" in it):

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12pre) Gecko/20110220

I'm curious to know if they're simply looking for "Firefox" in a certain place or if they're (un)intentionally breaking (specifically) Firefox 4.

It would also be useful to test with Seamonkey (or Camino) with the "like Firefox" portion of the UA string removed.
Fails...

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12pre) Gecko/20110220 Firefox/4.0b12pre

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12pre) Gecko/20110220

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/



Works...

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US;
rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/20101203

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/20110220

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12pre) Gecko/20110220 Firefox/3.6.13


Does that help at all?
Oh and interesting this one fails too (ie date set over 2011):

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/20110220 Firefox/3.6.13

However as you can see from comment 11, 2011 dates do work ok, as long as "Firefox/" isn't mentioned.

Seems like their user agent sniffing is completely messed up.
(In reply to comment #12)
> However as you can see from comment 11, 2011 dates do work ok, as long as
> "Firefox/" isn't mentioned.

Correction: They work ok as long as Firefox not mentioned as well as rv:1.9.2.13

When will these sites learn...

Comment 14

7 years ago
Chris B: Feel free to poke them about this, too, and point them to this bug.
Assignee: english-us → cab26715
(Assignee)

Comment 15

7 years ago
(In reply to comment #14)
> Chris B: Feel free to poke them about this, too, and point them to this bug.

To date, I have not received a response from Monster.com, so I don't know if this should be left open or closed.  It won't get fixed if Monster.com just wants to ignore the problem.
Does the issue still occur on new job pages?
(The testcase URL returns job not found now)
(Assignee)

Comment 17

7 years ago
(In reply to comment #16)
> Does the issue still occur on new job pages?
> (The testcase URL returns job not found now)

This bug only appeared on ONE job posting.  Job postings expire every couple weeks and I am getting tired updating the URL every couple weeks for the past five months, because Monster.com is not fixing the issue or has not gotten back to me.  A final reason that I am closing this bug is that I just landed a full time job, so I won't be using sites like Monster.com for quite a while.  This bug is now being marked as "Resolved Worksforme".
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.