Search Bar will not "search"

RESOLVED DUPLICATE of bug 593694

Status

()

--
major
RESOLVED DUPLICATE of bug 593694
8 years ago
8 years ago

People

(Reporter: andrew_fung, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8) Gecko/20100101 Firefox/4.0b8
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8) Gecko/20100101 Firefox/4.0b8

The search bar will not "hit enter" so to speak to enable a search. 

Reproducible: Always

Steps to Reproduce:
1.type in something
2.try to hit search.
3.
Actual Results:  
Nothing happens

Expected Results:  
Search the typed info in the search bar.

Updated

8 years ago
Hardware: Other → x86
Version: unspecified → Trunk

Comment 1

8 years ago
Try a more recent build.  You have a software date of January 1, 2010.  A lot of bugs were fixed within the past 11.5 months.
He actually has a really messed up ua, it says b8, but has an old build date.
(Reporter)

Comment 3

8 years ago
i didn't even see the software date. weird. I am using Beta 8 as Tyler has pointed out. Thanks.
Duh, totally forgot, beta releases use 20100101 as the us from now on. Sorry about the confusion.
Andrew, does it also happen in safe mode (http://support.mozilla.com/en-US/kb/Safe Mode) or with a fresh profile (http://support.mozilla.com/en-US/kb/Managing+profiles)?
(Reporter)

Comment 6

8 years ago
Henrik, I just tried both safe mode and a fresh profile with no luck. Still can not search in the search bar.
Does it mean it doesn't respond to Enter nor clicking the magnifier icon? Do you see any error message in the Error Console (reachable via the Tools menu)?
(Reporter)

Comment 8

8 years ago
Yes Henrik, it does not respond to Enter or clicking the magnifier.
The Error Console shows and Error: this.currentEngine.getSubmission is not a function. Source file: chrome://browser/content/search/seach.xml.

I'm not sure what it has to do with "Chrome", but i do have the Chrome browser installed too.
Interesting. Did you upgrade Firefox on your box? If yes, can you install the beta 8 to another folder and try again? I wonder if something went wrong with the upgrade.

(In reply to comment #8)
> I'm not sure what it has to do with "Chrome", but i do have the Chrome browser
> installed too.

It has nothing to do with Chrome. Chrome in Firefox means the user interface of the application, compared to content which are web pages displayed in tabs.
(Reporter)

Comment 10

8 years ago
Hmmm. I did upgraded it when Firefox prompted me to upgrade to Beta 8.
I just redownloaded the Beta 8, and reinstalled it with no success for the search bar. 


(In reply to comment #9)
> Interesting. Did you upgrade Firefox on your box? If yes, can you install the
> beta 8 to another folder and try again? I wonder if something went wrong with
> the upgrade.
> 
> (In reply to comment #8)
> > I'm not sure what it has to do with "Chrome", but i do have the Chrome browser
> > installed too.
> 
> It has nothing to do with Chrome. Chrome in Firefox means the user interface of
> the application, compared to content which are web pages displayed in tabs.

Comment 11

8 years ago
I also get this. I am running the latest nightly on the mac. I have only one extension (bugzilla tweaks). Search bar doesn't work. I get the same error message in the error console.
(Reporter)

Comment 12

8 years ago
(In reply to comment #11)
> I also get this. I am running the latest nightly on the mac. I have only one
> extension (bugzilla tweaks). Search bar doesn't work. I get the same error
> message in the error console.

i'm glad i'm not the only one!
(In reply to comment #8)
> Yes Henrik, it does not respond to Enter or clicking the magnifier.
> The Error Console shows and Error: this.currentEngine.getSubmission is not a
> function. Source file: chrome://browser/content/search/seach.xml.

So the code is located here:
http://mxr.mozilla.org/mozilla-central/source/browser/components/search/content/search.xml#485

That would mean that currentEngine is not a valid engine and probably is null. Andrew, can you please re-check it with a fresh profile and switch between all the installed search engines? Does the issue mentioned on this bug happen for each engine? Also which locale are you using?
(Reporter)

Comment 14

8 years ago
Hey Henrik

I set up a fresh profile and saw that the search bar worked. I went back to the old profile and found all the search engines were gone. That is probably why it probably wouldn't search. I just clicked on the down arrow in the search bar, hit manage search engines, and restore defaults. It works again. thank a bunch!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
By any chance, do you have an old version of the search.sqlite file from your profile? But I think this bug is in general a dupe of bug 593694.

Thanks for your feedback.

Sheila, would be great if you could send me or attach your search.sqlite file.
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 593694
(Reporter)

Comment 16

8 years ago
(In reply to comment #15)
> By any chance, do you have an old version of the search.sqlite file from your
> profile? But I think this bug is in general a dupe of bug 593694.
> 
> Thanks for your feedback.
> 
> Sheila, would be great if you could send me or attach your search.sqlite file.
> 
> *** This bug has been marked as a duplicate of bug 593694 ***

I don't think i have the search.sqlite file... where would it be stored?
(In reply to comment #16)
> I don't think i have the search.sqlite file... where would it be stored?

It's in the profile. You can reach the folder via the Troubleshooting menu entry under the Help menu. But you will need a backup. The current version doesn't really help. Sheila, but your one would be very welcome!
(Reporter)

Comment 18

8 years ago
(In reply to comment #17)
> (In reply to comment #16)
> > I don't think i have the search.sqlite file... where would it be stored?
> 
> It's in the profile. You can reach the folder via the Troubleshooting menu
> entry under the Help menu. But you will need a backup. The current version
> doesn't really help. Sheila, but your one would be very welcome!

I don't think i have a backup. Sorry.
You need to log in before you can comment on or make changes to this bug.