Clean up ContentParent cruft

RESOLVED FIXED in mozilla5

Status

()

defect
RESOLVED FIXED
9 years ago
6 years ago

People

(Reporter: jdm, Assigned: jdm)

Tracking

unspecified
mozilla5
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

Assignee

Description

9 years ago
ContentParent has accumulated some weird bits in GetSingleton that don't really make sense to me.  OnAccelerationChange is also funky, as it attempts to get a singleton for what is presumably the current object.
Assignee

Comment 1

9 years ago
Posted patch Clean up ContentParent cruft. (obsolete) — Splinter Review
Attachment #499775 - Flags: review?(benjamin)

Updated

9 years ago
Assignee: nobody → josh

Comment 2

9 years ago
Comment on attachment 499775 [details] [diff] [review]
Clean up ContentParent cruft.

I really hate that all the observer-adding is done in GetSingleton anyway. If you're going to refactor this, please move all that into an Init() method. That way when we have multiple content processes we don't have to touch this all yet again.
Attachment #499775 - Flags: review?(benjamin) → review-
Assignee

Comment 3

8 years ago
Posted patch Clean up ContentParent cruft. (obsolete) — Splinter Review
Here's the Init() version.  I also noticed that the current thread observer mechanism will break when we move to multiple content processes, but that's not something I want to address right now.
Attachment #511038 - Flags: review?(benjamin)

Updated

8 years ago
Attachment #511038 - Flags: review?(benjamin) → review+
Assignee

Comment 4

8 years ago
Comment on attachment 511038 [details] [diff] [review]
Clean up ContentParent cruft.

This is good cleanup of some code that's become a bit of a dumping ground.
Attachment #511038 - Flags: approval2.0?

Comment 5

8 years ago
Comment on attachment 511038 [details] [diff] [review]
Clean up ContentParent cruft.

Can you provide a risk/reward analysis? I really don't want to go taking cleanup patches at this point unless they fix some known issue.
Attachment #511038 - Flags: approval2.0?
Assignee

Comment 6

8 years ago
Nevermind, there's no real need to take this right now.
Assignee

Updated

8 years ago
Depends on: post2.0
Attachment #499775 - Attachment is obsolete: true
This patch doesn't apply cleanly on trunk anymore.
Whiteboard: not-ready
Assignee

Updated

8 years ago
Attachment #511038 - Attachment is obsolete: true
Assignee

Updated

8 years ago
Whiteboard: not-ready
http://hg.mozilla.org/mozilla-central/rev/f008fc60b3d4
Status: NEW → RESOLVED
Last Resolved: 8 years ago
No longer depends on: post2.0
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.2
Duplicate of this bug: 639867
Assignee

Updated

8 years ago
Blocks: 645359

Updated

6 years ago
Duplicate of this bug: 639865
You need to log in before you can comment on or make changes to this bug.