Notification alert for normal tabs

RESOLVED DUPLICATE of bug 588589

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 588589
8 years ago
8 years ago

People

(Reporter: insanities, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b9pre) Gecko/20101225 Firefox/4.0b9pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b9pre) Gecko/20101225 Firefox/4.0b9pre

Internet Explorer has this feature I don't know about the beta. The previous versions of IE definitely had a orange flash over tabs requiring attention. Almost all versions of Windows Taskbar has a bright orange notification also. Windows 7 has a nice glow/flash that flashes for a few seconds before finally staying bright orange until attention is received.

This glow/alert could be activated by the name of a tab changing, such as on Facebook: New message from "name".
Or a notification for email, Facebook, whatever something like: (*)
The wildcard could be any number of notifications.

This especially would be helpful apptabs which have no way of notifying a user of a change. I think Chrome has this feature with apptabs but with a shaking effect?

Reproducible: Always

Steps to Reproduce:
1. Talk to someone on Facebook, pin as app tab.
2. No way of noticing that you've received a new message from your mate.
(Reporter)

Comment 1

8 years ago
Created attachment 499789 [details]
My New Notification Mockup (Windows 7 like)
(Reporter)

Updated

8 years ago
Summary: New tab/app tab notification/alert → Notification alert for tabs/app tabs

Updated

8 years ago
Severity: normal → enhancement
OS: Windows 7 → All
Hardware: x86 → All
Version: unspecified → Trunk
So how does it currently look for you? Can you please attach a screenshot? App tabs should always get highlighted.
(Reporter)

Updated

8 years ago
Summary: Notification alert for tabs/app tabs → Notification alert for tabs
(Reporter)

Comment 3

8 years ago
Ah sorry, just realised that this was recently implemented in app tabs but still not in regular tabs. 
It should be implemented in regular tabs especially when in tab overflow, title changes could not be very clearly noticed because the tabs are so small.

The red gradient could be changed to the bright orange like in the attached image. The plain dark red is a bit of a forceful/dull colour.
Lets get feedback from UX then.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: uiwanted
Summary: Notification alert for tabs → Notification alert for normal tabs
(Reporter)

Comment 5

8 years ago
Um, I found another bug similar to mine...
Has the same intentions as mine I think:
https://bugzilla.mozilla.org/show_bug.cgi?id=588589

Sorry if it's a duplicate :(
Yeah, that's a dupe. Thanks for finding it!
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Keywords: uiwanted
Resolution: --- → DUPLICATE
Duplicate of bug: 588589
You need to log in before you can comment on or make changes to this bug.