Very High CPU usage on pl.playstation.com

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: alice0775, Unassigned)

Tracking

(Blocks 1 bug, {perf, regression})

Trunk
mozilla2.0
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

9 years ago
Build Identifier:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20101226 Firefox/4.0b9pre ID:20101226030348

High CPU usage on pl.playstation.com.
CPU usage around 50% and more.

CPU usage become around 25% if dom.ipc.plugins.enabled=false and gfx.direct2d.disabled=true. And CPU usage is same as Firefox3.6.14pre.

CPU usage is less than 5% on Google Chrome10.0.614.0.

*CPU: Core2Quad Q8300 @2.5GHz, 4GBRAM, ATI HD4350
*CPU usage measured after loading completion of the page, and It is the approximate mean value.

Reproducible: Always

Steps to Reproduce:
1. Start Minefield with new profile
2. Open ( http://pl.playstation.com/ps3/games/detail/item241009/Gran-Turismo%C2%AE-5/ )
3. Wait for the loading completion of the page.
4. Watch CPU usage

Actual Results:
 Very high CPU usage

Expected Results:
 The CPU usage should be Firefox3.6.x degree at least


Rgression(improvement) window(cached hourly):
*less 20%
http://hg.mozilla.org/mozilla-central/rev/92339b84d089
Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; en-US; rv:2.0b2pre) Gecko/20100715 Minefield/4.0b2pre ID:20100715145415

*Pushlog regression 25% from 20%:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=92339b84d089&tochange=e1d7fd5255fd
Candidate: Bug 564991 - Retain layers and layer contents
http://hg.mozilla.org/mozilla-central/rev/e1d7fd5255fd
Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; en-US; rv:2.0b2pre) Gecko/20100715 Minefield/4.0b2pre ID:20100715152722
http://hg.mozilla.org/mozilla-central/rev/69e2e34ccddc
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100813 Minefield/4.0b4pre ID:20100813065209

*Pushlog regression 30% from 25%:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=69e2e34ccddc&tochange=9fd11a17eb1a
http://hg.mozilla.org/mozilla-central/rev/9fd11a17eb1a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100813 Minefield/4.0b4pre ID:20100813072506
http://hg.mozilla.org/mozilla-central/rev/f001894b50ea
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100817 Minefield/4.0b5pre ID:20100817192012

*Pushlog regression 40% from 30% and UI become barely responds:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f001894b50ea&tochange=984f55359541
Candidate: Bug 549116 - (d2d) Enable Direct2D by default
http://hg.mozilla.org/mozilla-central/rev/984f55359541
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100817 Minefield/4.0b5pre ID:20100817214337
http://hg.mozilla.org/mozilla-central/rev/212a391d3b79
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101109 Firefox/4.0b8pre ID:20101110052514

*Pushlog regression 50% from 40% and but UI response improved:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=212a391d3b79&tochange=bdbef533364f
Candidate: Bug 596451 - Asynchronous layer-based plugin painting on Windows
http://hg.mozilla.org/mozilla-central/rev/bdbef533364f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101109 Firefox/4.0b8pre ID:20101110081923
Direct2D vs. non-Direct2D regression is related to the fact we no longer have GDI DCs for the plugin to draw to directly, causing us to go through a more complicated drawing path, 2 possible methods of mitigation are:

- Jeff tried making Direct2D interop work well, but I believe there were a number of (possible non-surmountable) issues.
- Avoiding alpha recovery if the flash plugin gives us proper alpha values in a plain DC.

I'm not sure if both are still valid now that we have asynchronous painting.

Comment 2

9 years ago
I experience this issue on Windows XP, so any solution should take into account platforms that have absolutely no support for Direct2D.
Well, this is no ordinary web page, just looking through Page Info Media.. 

This page is got a lot of junk on it, and I mean a lot of images, large images, both super long and skinny and a lot of large background images, some I'm not sure if they are even visible on the page.

There also appears be heavy javascript and a scroller in the middle of the page, and at least 2 flash videos with plenty of divs mixed in.
Blocks: slowui
WFM also.  ~4-5% cpu
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:16.0) Gecko/16.0 Firefox/16.0a1

d2d settings...

Adapter Description ATI Radeon HD 4550   
Vendor ID0x1002
Device ID0x9540
Adapter RAM512
Adapter Driversaticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
Driver Version8.881.0.0
Driver Date7-28-2011
Direct2D Enabledtrue
DirectWrite Enabledtrue (6.1.7601.17789)
ClearType ParametersDISPLAY1 [ Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 200 ] DISPLAY2 [ Gamma: 2200 Pixel Structure: RGB ClearType Level: 50 Enhanced Contrast: 300 ] 
WebGL RendererGoogle Inc. -- ANGLE (ATI Radeon HD 4550   ) -- OpenGL ES 2.0 (ANGLE 1.0.0.1041)
GPU Accelerated Windows0
AzureBackenddirect2d
Reporter

Comment 5

7 years ago
I cannot reproduce anymore in
http://hg.mozilla.org/releases/mozilla-esr10/rev/5713c92407dd
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0.5) Gecko/20100101 Firefox/10.0.5 ID:20120531185831
and
http://hg.mozilla.org/releases/mozilla-release/rev/f48d675ffa9f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0.1 ID:20120614114901

set WFM
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.