Firefox disappears after plugging / unplugging external monitor

RESOLVED WORKSFORME

Status

()

Core
Graphics
--
major
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: Marcin Okraszewski, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b8) Gecko/20100101 Firefox/4.0b8
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b8) Gecko/20100101 Firefox/4.0b8

It might be related to bug 591532. When I plug or unplug external monitor, the FireFox disappears but it is still in task bar. Only FF restart helps. The minimize / maximize / restore run from right-click on task bar does not help. Though I can see it is restored to right place (though restore animation), not outside screen. But after "animation" I cannot see FF, not even the title bar. When unplug and plug again monitor still FF does not appear. 

It happens to both FF 4.0 beta 7 and 8. Does not happen to 3.6.

Unfortunately it happens I plug and unplug the external monitor several times a day. If I forget to check if some forms are open, it happens I lose them.  



Reproducible: Always

Steps to Reproduce:
1. Start FF
2. Unplug or plug external monitor

Actual Results:  
Firefox disappears.

Expected Results:  
It should be still visible. If external monitor was unplugged, then it should be moved to remaining one. 

It might be related to hardware acceleration therefore additional info:
1. System: Windows XP Pro EN SP3
2. Laptop: Dell E6400
3. Graphic card: Nvida Quadro NVS 160M, driver version: 188.40, Video BIOS version: 62.98.3C.00.01
4. External LCD: Dell 2007FP plugged through analog cable

It happens to FF 4.0 b7 and 8 (I didn't use older). Does not happen to 3.6
(Reporter)

Updated

8 years ago
Version: unspecified → Trunk
So it seems like Firefox is still open, just open on an unviewable region of the window (since there is no screen there)?
Severity: critical → major
(Reporter)

Comment 2

8 years ago
No. It could be true if it happened only when I unplug monitor, but it happens also when I plug monitor. What's more when I had FF running in foreground and pugged in the external monitor, the whole FF region was black. When I switched to same app, it painted over it, but then switching back to FF makes like no change. Additionally, as I wrote earlier - when I minimize / maximize window I can see the region it is supposed to take - Windows animate the path of the window from / to the task bar. It is on a screen, not out of it.
Can you update your graphics driver version? the one you are using is pretty out of date, I believe the latest is around 260.xx
Please disable the hardware acceleration in the options (advanced/general)
(Reporter)

Comment 5

8 years ago
Upgrade to latest drivers from NVidia 260.99 doesn't help. Latest from Dell (189.92) didn't help as well (I didn't know drivers from Dell are so far behind).

Disabling hardware acceleration DOES help. It confirms to be hardware acceleration issue. It is good as a workaround, therefore severity drops, but obviously I would like to use full performance potential of the new FF.
(Reporter)

Comment 6

8 years ago
One more thing to add. Opera 11.0, which I think is using hardware acceleration as well, does not the same issue.
>It is good as a workaround
I asked only to narrow down the issue and to find the right component (Product Firefox is wrong in any case)

Can you please retest with a nightly build ?
-> ftp://ftp.mozilla.org/pub/firefox/nightly/latest-mozilla-central/
Component: General → Graphics
Product: Firefox → Core
QA Contact: general → thebes
(Reporter)

Comment 8

8 years ago
I'll check it next week, since I'm out now without access to an external screen.
(Reporter)

Comment 9

8 years ago
I've just check 4.0b9pre (2011-01-03) and it is exactly the same. 

One more funny symptom - when I move over the FF area mouse pointer changes (text, arrow, hand) according to object that is supposed to be under.
Can you please post the graphic section from about:support ?
(Reporter)

Comment 11

8 years ago
Created attachment 501017 [details]
Support Information

Attaching the whole result of about:support.
(Reporter)

Comment 12

8 years ago
4.0 beta 9 is still having the issue.
(Reporter)

Comment 13

8 years ago
Seems like beta 11 fixed the issue :-)
Great, marking wfm in that case !
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.