Closed Bug 621567 Opened 12 years ago Closed 12 years ago

Bookmark list is damaged after update to Sync 1.6

Categories

(Firefox :: Sync, defect)

x86_64
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 618403

People

(Reporter: mozilla, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.9.2.13) Gecko/20101209 Fedora/3.6.13-1.fc14 Firefox/3.6.13
Build Identifier: 1.6

After updating to Sync 1.6 and syncing the bookmarks, the bookmark list is damaged:

* Some bookmarks or separators are duplicated.
* Some bookmarks are moved to a wrong position.
* Some bookmarks are lost. (Reported, I could not yet reproduce lost bookmarks myself.)

When trying to move bookmarks back to the original position by drag and drop, the bookmark can be dragged, but when dropping, it just stays at the wrong position. After a while, dragging bookmarks is not possible any more.

Reproducible: Always

Steps to Reproduce:
1. Update to Sync 1.6.
2. Change and then synchronize bookmarks between two or more machines.
3. Check the bookmarks.
4. Try to move bookmarks.
Actual Results:  
Some bookmarks are duplicated or moved to a wrong position. When trying to move them back, nothing happens.

Expected Results:  
Behaviour like previous versions of Sync.

Also see https://addons.mozilla.org/en-US/firefox/addon/10868/reviews/ for other people complaining about this bug.

Severity "Critical", because the software causes damage to or loss of user data. 

Note that it is not possible to revert to a previous version of Sync because after the update, the database requires at least Sync 1.6.
Sorry that you experienced data loss! The good news is that Sync makes a backup of your bookmarks before each Sync. Just go to Bookmarks -> Organize Bookmarks -> star icon -> Restore.

Now I know we have some duplication issues (bug 618403) and some reordering issues, but I'm not aware of lost bookmarks. Can you confirm they're gone and weren't just moved to Unsorted Bookmarks?

Could you please go to about:sync-log, save the log and attach it to this bug? Thanks!
Btw, do you have any smart bookmarks?
I have looked for a bug report, but I must have missed bug 618403. I'm sorry about that. However, that bug is from Dec 10, so Sync 1.6 was rolled out even though the bug was already known?

A review commentor (https://addons.mozilla.org/en-US/firefox/addon/10868/reviews/260334/) said that bookmarks were lost. I have several thousands of bookmarks - way too much to thoroughly check for losses. But I have noticed no losses so far...

I have never heard of smart bookmarks, so I guess I have none. :)

I will close this bug as duplicate, and continue at but 618403.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 618403
(In reply to comment #3)
> I have looked for a bug report, but I must have missed bug 618403. I'm sorry
> about that. However, that bug is from Dec 10, so Sync 1.6 was rolled out even
> though the bug was already known?

At that point is was an unconfirmed issue we could not reproduce. We've received several reports since then, though, so we're pretty sure it's an issue. It's still hard to reproduce reliably and we're not sure what's causing it.

> I have never heard of smart bookmarks, so I guess I have none. :)

Ok, good to know. Thanks!
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.