Table submenus in popup context menu don't update until toplevel "Table" menu is used.

VERIFIED FIXED in mozilla0.9

Status

()

Core
Editor
P5
normal
VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: Nasiruddin M.S, Assigned: Charles Manske)

Tracking

Trunk
mozilla0.9
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: suntrak-n6)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Netscape Build : 12/04/2000
Platform : Solaris2.8(sparc)

To reproduce,
(1) Launch the browser
(2) Launch the composer.
(3) Insert a table by clicking on Table->Insert->Table.
(4) A table insert window pops up.Click on 'ok' button.
(5) Position the cursor on  table just created. Right click on the mouse button.
This will display side menu.
(6)Look into 'Table Select','Table insert','Table Delete' options.

Expected result: You should see all the sub-options enabled for above options.

Actual result: The sub-options are disabled.
(Reporter)

Updated

17 years ago
Priority: P3 → P5
Whiteboard: suntrak-n6

Comment 1

17 years ago
Happens on Linux, too.  Are the options enabled on windows/mac?

Comment 2

17 years ago
Options are disabled on Win32 too.

Comment 3

17 years ago
Changing Platform and OS from Sun/Solaris to All/All since it seems to be xp.
OS: Solaris → All
Hardware: Sun → All

Comment 4

17 years ago
Passing off to cmanske@netscape.com.
Assignee: beppe → cmanske
(Assignee)

Comment 5

17 years ago
I can't reproduce this on Windows NT with either the RTM NS6 build or my
current debug build.

Comment 6

17 years ago
Hmmm, it's working in my 12/15/00 Win32 trunk debug build too.

Akkana, can you do me a favor and see if it's fixed on Linux too?

Comment 7

17 years ago
In today's linux build, clicking on the ok button in the table dialog does not
insert a table (and the dialog doesn't go away).  I can't test this bug until
that problem is fixed.  Will file a bug on that problem.
(Assignee)

Comment 8

17 years ago
I think someone has done some general damage to the dialog system! Other problems
are cropping up, like for the Color Picker (bug 62947)
(Assignee)

Comment 9

17 years ago
Unless I get some confirmation about this bug, it will be marked "WORKSFORME".

Comment 10

17 years ago
The table insert dialog is working again, so I can test this now, and on linux,
I do see the problem as described here: under Table Insert, all options except
Table are greyed out; under Table Delete, all options are greyed out.
(Assignee)

Comment 11

17 years ago
Akkana: So you see this only on Linux? Any other menu items grayed out that you
think shouldn't be? It's really strange if this is only on Linux.

Comment 12

17 years ago
I haven't tried it on anything but Linux.  I don't notice anything in the main
menubar that's greyed out that shouldn't be (though I've seen chronic problems
in the past with copy/paste being greyed out when they shouldn't, but I didn't
see that when I checked just now) but I'll be glad to check particular menus if
you have any you want checked.
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
OS: All → Linux
Hardware: All → Other
Target Milestone: --- → mozilla0.8
(Assignee)

Comment 13

17 years ago
Akkana: Are other submenu items enabled appropriately, like those in the Format
menu?
The code to enable most of the table submenu items is this:
  return (window.editorShell && window.editorShell.documentEditable &&
          null != window.editorShell.GetElementOrParentByTagName("table", null));

GetElementOrParentByTagName is used in many places; you couldn't bring up
Table Properties if that doesn't work. So there's nothing in editor code that
suggests why this problem occurs.


Changing OS to just Linux.
(Assignee)

Comment 14

17 years ago
Another Linux-only problem. Maybe a dup of 63378?
Assignee: cmanske → anthonyd
Status: ASSIGNED → NEW
Summary: The table side menu properties are disabled. → Linux: The table side menu properties are disabled.

Comment 15

17 years ago
moving to moz0.9.1
Target Milestone: mozilla0.8 → mozilla0.9.1

Comment 16

17 years ago
*** Bug 71412 has been marked as a duplicate of this bug. ***

Comment 17

17 years ago
1) The OS of this bug should be set to ALL as said by kin@netscape.com 2000-12-
08 09:54
2) Description of Bug 71412 is better: "Table Select and Table Delete context 
menu subitems don't update until Table mainmenu is used"

From bug 71412:
Seen on Windows 2000, Build 2001030804 installer
Way to reproduce:
a) Open new Composer window
b) Insert a table
c) right-click on the table, and choose 'Table Select'
-> Expected: subitems Enabled (Table, Row, Column ..)
   Result: subitems are disabled.
d) goto the mainmenu 'Table' and look in the Select submenu
All subitems are enabled
e) Close mainmenu, go back to the table and rightclick again.
f) Go back to the 'Table Select' submenu. This time all items are enabled.

------- Additional Comments From Dean Tessman 2001-03-09 08:59 -------
...It appears that the context menu doesn't have any enabling/disabling code.  
It all seems to be in the Table menu.  If I pop down the Table menu and then go
back to the table context menu, the commands are properly enabled...


Comment 18

17 years ago
Moving platform/os back to all/all, since I'm seeing this on Win2K.  Based on my
observations, I'd also like to re-summarize to "Table Select and Table Delete
context menu subitems don't update until Table mainmenu is used", but I'll leave
that for someone else to do.
OS: Linux → All
Hardware: Other → All

Comment 19

17 years ago
This sounds like something in cmanske's ballpark. Reassigning back to cmanske.
Assignee: anthonyd → cmanske
(Assignee)

Comment 20

17 years ago
I think I finally see what the problem is!
Status: NEW → ASSIGNED
(Assignee)

Comment 21

17 years ago
Created attachment 27292 [details] [diff] [review]
Proposed fix
(Assignee)

Comment 22

17 years ago
Kin or Akkana: can one of you please test this simple fix on Linux? (I'm
working at home today.)
(Assignee)

Comment 23

17 years ago
Changing summary
Summary: Linux: The table side menu properties are disabled. → Table submenus in popup context menu don't update until toplevel "Table" menu is used.
(Assignee)

Comment 24

17 years ago
Very easy - would like to fix for 8.1
Whiteboard: suntrak-n6 → suntrak-n6 FIX IN HAND need r=, sr=
Target Milestone: mozilla0.9.1 → mozilla0.8.1
(Assignee)

Comment 25

17 years ago
Created attachment 27479 [details] [diff] [review]
Update patch: removed command updates that are done by "goUpdateTableMenuItems"
(Assignee)

Comment 26

17 years ago
Fix checked in and should be in 3/13 build.
Please help test this on all platforms.
Whiteboard: suntrak-n6 FIX IN HAND need r=, sr= → suntrak-n6

Comment 27

17 years ago
Can't test on today's build, the toolbar items (including table) are all greyed out.
(Assignee)

Comment 28

17 years ago
Moving to 0.9 to get off the 0.8.1 radar.
Still needs testing to confirm fix on all platforms.
Target Milestone: mozilla0.8.1 → mozilla0.9

Comment 29

17 years ago
Following ajbanck@casema.net's repro instructions of 2001-03-09 09:24, I do not
see this in the 3/13 build after pulling joki's fix for bug 71224.  (I have to
type something in the composer window before I can insert a table, though, to
make the toolbars enable.)

Comment 30

17 years ago
I can't reproduce the problem after applying the patch. Windows 2000.
(Assignee)

Comment 31

17 years ago
Akkana: So do you see a caret in content area when you first start Composer?
I don't see that problem in WinNT. Everything is just fine again.
So maybe we still have initial focus problems just in Linux?

Comment 32

17 years ago
Yes, I do see a blinking caret when I start up, even when the toolbar buttons
are not enabled.
(Assignee)

Comment 33

17 years ago
I haven't received any reports that this bug still exists. Marking fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 34

17 years ago
Just finally downloaded a new build.  Works well.  Verifying using 2001031604 on
Win2000.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.