Clicking "Get more Search Engines" in Firefox ends up in search tools on AMO

VERIFIED FIXED in 2013-11-12

Status

addons.mozilla.org Graveyard
Public Pages
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: whimboo, Assigned: vinyll)

Tracking

(Depends on: 1 bug, {regression})

unspecified
2013-11-12
regression
Bug Flags:
in-qa-testsuite ?

Details

(Whiteboard: [see comment 17], URL)

When you open the search engine manager and click on "Get more Search Engines", an AMO page gets opened but only search tools and no engines are listed. This is a regression and should have been changed in the last couple of weeks.

Clicking the above mentioned link in Firefox should open, i.e:
https://addons.mozilla.org/en-US/firefox/search-engines/

But there is a redirect, which immediately redirects the user to:
https://addons.mozilla.org/en-US/firefox/search-tools/

From the user perspective the listed results don't make sense. We should really list search engines (providers) as what we have done before. All versions of Firefox are affected by that change on AMO.
Version: ACR-0.* → unspecified
We should be able to expand our Mozmill test to cover a regression like that.
Whiteboard: [mozmill-test-needed]
Justin, something  we can do in a short term to get this issue fixed?
Justin, ping? Would be nice if we can get some action on this issue.
Duplicate of this bug: 646301
Please fix the redirect to go to the search providers page.
Target Milestone: --- → 6.1.5
(In reply to comment #5)
> Please fix the redirect to go to the search providers page.

Would you link to the page you have in mind?

Andy: this may be in remora's .htaccess
Assignee: nobody → amckay

Comment 7

7 years ago
Search engine page was bounced to search tools in:

https://bugzilla.mozilla.org/show_bug.cgi?id=573166
https://github.com/jbalogh/zamboni/commit/cc172a10

It shows addons that are search engines. Not sure what to point to.
It sounds like that we want to point users to:
https://addons.mozilla.org/en-US/firefox/search-tools/multiple-search

Or is that only a sub-set of all the available search engines on AMO?
(In reply to comment #8)
> It sounds like that we want to point users to:
> https://addons.mozilla.org/en-US/firefox/search-tools/multiple-search
> 
> Or is that only a sub-set of all the available search engines on AMO?

That's just a subcategory of all the search providers (see list of categories on the left)
Target Milestone: 6.1.5 → 6.1.6
We don't seem to have a page that lists all search providers regardless of category. Maybe we should punt this until we can fix that with impala?

Ideally this would link to the featured search providers.
Target Milestone: 6.1.6 → 4.x (triaged)

Comment 11

6 years ago
Here, clicking the "Get more search engines" URL now goes to 

http://bodisparking.com/peersbros.com

via a redirect from 

www.searchplugins.peersbros.com

so I guess the problem is no nearer being fixed.
The Mycroft project provides a large collection of Search Engine Plugins for Firefox:

http://mycroft.mozdev.org/
Depends on: 684297

Comment 13

6 years ago
100% agree. 

Clicking "Get more search engines..." should take the user to http://mycroft.mozdev.org/ where you can find much more variety and 100s of useful results.

At the moment it takes you to https://addons.mozilla.org/en-US/firefox/search-tools/ where there are only 17 results.

Updated

5 years ago
Assignee: amckay → nobody
Keywords: uiwanted
There was a proposal to redesign this in bug 684297:

http://f.cl.ly/items/0c0K0U2z1z16461q3R2P/Untitled-1.png
That design doesn't solve the main problem, which is that there's no way to get to a search engines section on AMO, where one can find all search engines (type=4 add-ons) that are listed on the site.

I think we clearly need 2 different pages, one for search engines and one for extensions in the Search Tools category.

Comment 16

4 years ago
Hi,

is there any update to this?

Thanks
This bug is about adding a redirect (301 is fine) from https://addons.mozilla.org/en-US/firefox/search-engines/ to https://addons.mozilla.org/en-US/firefox/search/?atype=4

I suspect this is handled in the code somewhere around apps.browse.views.legacy_redirects
Keywords: uiwanted
Whiteboard: [mozmill-test-needed] → [mozmill-test-needed][see comment 17]
(Assignee)

Updated

4 years ago
Assignee: nobody → vagnano
(Assignee)

Comment 18

4 years ago
A PR in reply to #17 is at https://github.com/mozilla/zamboni/pull/1349
(Assignee)

Comment 19

4 years ago
Fixed in https://github.com/mozilla/zamboni/commit/fe154f510370218eba99d2d4435cd5232a5674d1
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: 4.x (triaged) → 2013-11-12
Vincent, can you please let us know when this fix has been pushed to production? Thanks.
Flags: needinfo?(vagnano)
(Assignee)

Comment 21

4 years ago
(In reply to Henrik Skupin (:whimboo) from comment #20)
> Vincent, can you please let us know when this fix has been pushed to
> production? Thanks.

Here's the merge timedate: 2013-11-07T10:19:56-08:00 ~> yesterday
Flags: needinfo?(vagnano)
It'll be pushed next tuesday around noonish
Thanks Wil! I will check it again once alive and will initiate that we create a mozmill test for it.
This works great now. Thanks for the fix. We will implement a Mozmill test on bug 941477.
Status: RESOLVED → VERIFIED
Depends on: 941477
No longer depends on: 684297
Flags: in-qa-testsuite?(hskupin)
Whiteboard: [mozmill-test-needed][see comment 17] → [see comment 17]
Removing my name from in-qa-testsuite flag for a better query.
Flags: in-qa-testsuite?(hskupin) → in-qa-testsuite?
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.