Last Comment Bug 621660 - Stylish 1.1b1 breaks the extension manager which in turn breaks application update
: Stylish 1.1b1 breaks the extension manager which in turn breaks application u...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Extension Compatibility (show other bugs)
: Trunk
: x86 Windows XP
: -- minor (vote)
: Firefox 4.0b6
Assigned To: christian
:
Mentors:
Depends on: 627406
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-28 01:08 PST by Terrell Kelley
Modified: 2011-01-20 14:40 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Requested error console output from Comment 1. (1.47 KB, text/plain)
2010-12-28 19:30 PST, Terrell Kelley
no flags Details
Add to the blocklist DB, which will then get slurped into the tree (106 bytes, text/plain)
2011-01-14 15:00 PST, christian
morgamic: review+
Details

Description Terrell Kelley 2010-12-28 01:08:32 PST
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b7) Gecko/20100101 Firefox/4.0b7
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b7) Gecko/20100101 Firefox/4.0b7

While I was able to successfully upgrade to this version from Beta 6, I cannot get it to work for Beta 8. When ever I use the About Firefox dialog, I get the spinner, and it never determines whether there is a new version or not.

I did not see this on the list of known issues, and, for all I know, you fixed it Beta 8.

Reproducible: Always

Steps to Reproduce:
1. Click Help on either the Firefox button or the menu bar.
2. Click About Firefox.
Actual Results:  
Dialog box continually says "Checking for updates."

Expected Results:  
Dialog box should say "Update Found,"  "Click here to update," and/or similar.

I'm using a copy of a profile I've been using since Firefox 3.0.

And do remember that this worked properly back on Beta 6.

And please do not ignore because it's from Beta 7, as your feedback button seems to claim you will. It would be improper to say the bug was in Beta 8.

The "easy workaround is to install Beta 8 manually."
Comment 1 XtC4UaLL [:xtc4uall] 2010-12-28 09:43:49 PST
Please set app.update.log (create it beforehand) in about:config to "true".
Try to Update again.
Then post your Error Console Output.
Comment 2 Terrell Kelley 2010-12-28 19:30:57 PST
Created attachment 500142 [details]
Requested error console output from Comment 1.
Comment 3 Terrell Kelley 2010-12-28 19:31:56 PST
It's hanging on the following:

Warning: WARN addons.manager: Exception calling callback: TypeError: aAddon.isCompatibleWith is not a function

Just in case, I put the rest of the output in an attachment. Sorry that I didn't realize that I could have included this message above.
Comment 4 Robert Strong [:rstrong] (use needinfo to contact me) 2010-12-28 19:34:03 PST
Please post a lit of the extensions you have installed.
Comment 5 Terrell Kelley 2010-12-28 22:26:03 PST
I can do you one better. Once I saw the error, I went through all my extensions. I know exactly which one was causing the problem.

Stylish 1.1b1, available here: https://addons.mozilla.org/en-US/firefox/addon/2108/#install-beta

I'm not closing, just in case the bug is with Firefox, not the extension.
Comment 6 Robert Strong [:rstrong] (use needinfo to contact me) 2010-12-28 22:32:28 PST
Thanks, moving over to add-on compatibility in the hope of getting the extension fixed. 

Note: there is bug 595078 to try to prevent extensions from doing this on the app update side and bug 595081 should also help.
Comment 7 Terrell Kelley 2010-12-29 00:10:13 PST
I do want to add that GreaseMonkey 2010.12.24.nightly also modifies the extension manager, but does not break updates.
Comment 8 Terrell Kelley 2010-12-29 00:11:25 PST
Oops, I forgot the URL:

https://arantius.com/misc/gm-nightly/
Comment 9 christian 2010-12-29 09:39:35 PST
This seems like a good candidate for blocklisting, yes? Just for FF4 that is.
Comment 10 Terrell Kelley 2010-12-29 18:16:16 PST
I don't know. The extension manager works, other than breaking application updates. And it only breaks them when an update exists. The user can easily install the update manually. (Something like the fix for Bug 595455 would be nice, though. If the update manager has hung for a certain amount of time, display a failure notice and add an option to download the update manually.)

Perhaps a block only on older versions of the 4.0beta would make sense. Is that possible?

Also, is anyone going to confirm?
Comment 11 Terrell Kelley 2011-01-11 06:27:48 PST
Okay, this is fixed in Stylish 1.1b3 on my end. I vote close RESOLVED, but I'll let you guys decide. 

If you want, blacklist anyone from downloading 1.1b1.
Comment 12 Robert Strong [:rstrong] (use needinfo to contact me) 2011-01-12 15:18:08 PST
I verified that with Stylish 1.1b1 still breaks the add-ons manager even with the code that somewhat locks down the add-ons manager. I think we should blocklist Stylish 1.1b1.

btw: the patch in bug 595078 fixes this for me.
Comment 13 christian 2011-01-14 15:00:11 PST
Created attachment 503997 [details]
Add to the blocklist DB, which will then get slurped into the tree
Comment 14 Michael Morgan [:morgamic] 2011-01-14 17:19:36 PST
Comment on attachment 503997 [details]
Add to the blocklist DB, which will then get slurped into the tree

Looks good to me.
Comment 15 christian 2011-01-20 14:27:15 PST
Filed bug 627406 for IT to update the production DB.
Comment 16 christian 2011-01-20 14:40:45 PST
This has been run on production and should now be fixed.

Note You need to log in before you can comment on or make changes to this bug.