I think the default column list needs reconsidering for the 21st century :-) (Inspired by bug 499546). Terry set it in the original Bugzilla code to: "severity", "priority", "platform", "assigned_to", "status", "resolution", "summary" http://bzr.mozilla.org/bugzilla/trunk/annotate/1972/globals.pl#L337 Today, it is: "severity", "priority", "op_sys", "assigned_to", "status", "resolution", "summary" http://bzr.mozilla.org/bugzilla/trunk/annotate/head:/Bugzilla/Constants.pm#L278 Notice the similarity :-) (The one change was bug 72948, in 2005). Here is a straw-man suggestion for a better set and ordering, based on the fields I think are most used and most important today: Product Component Assignee Keywords (or tags when we have them) Summary Status Resolution Last Changed Gerv
Keep the bug summary at the very end. Also, I'm not sure how useful the product is. When you look for bugs, you are already supposed to restrict your query to products you are looking for.
Severity: normal → enhancement
This is the thing. 10 years ago, everyone used the complex query form, and restricted by product. These days, people type a few words into the search box, Google style, and hit Enter. So they'll get back bugs from many products. Being able to see which are in the right product, and to sort the list by product (when we have column sorting, which b.m.o. already has) makes this much easier. I'm not too fussed about the order :-) Gerv
Max: do you have a view on this? Gerv
Yeah, I think your suggestion is good with some minor changes: Product Component Assignee Status Resolution Summary Last Changed
Created attachment 507207 [details] [diff] [review] Patch v.1 Matching Max's list. Gerv
Assignee: query-and-buglist → gerv
Status: NEW → ASSIGNED
Attachment #507207 - Flags: review?(mkanat)
Attachment #507207 - Flags: review?(LpSolit)
Comment on attachment 507207 [details] [diff] [review] Patch v.1 Looks good to me.
Attachment #507207 - Flags: review?(mkanat) → review+
It would be nice to have LpSolit sign off on it also, BTW, before we commit.
Comment on attachment 507207 [details] [diff] [review] Patch v.1 I'm personally more used to have the changed date as the first field, but this is still an improvement over what we have currently. So r=LpSolit
Attachment #507207 - Flags: review?(LpSolit) → review+
Comment on attachment 507207 [details] [diff] [review] Patch v.1 Fwiw, r=Wurblzap
Attachment #507207 - Flags: review+
Committing to: bzr+ssh://bzr.mozilla.org/bugzilla/trunk/ modified Bugzilla/Constants.pm Committed revision 7679. Gerv
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.