Closed Bug 621730 Opened 9 years ago Closed 9 years ago

Blue Highlighting rect calculation is wrong on google images

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: vingtetun, Assigned: vingtetun)

References

Details

Attachments

(1 file)

Attached patch PatchSplinter Review
Steps to reproduce:
 * go to google images
 * search for any images
 * wait for the resulting page to load
 * tap down on one of the results

Actual result:
 * a rect of 20px height is draw

Expected result: 
 * a rect of the height of the image is draw


Another steps to reproduce is:
 * go to http://vingtetun.org
 * tap down on the menu item "View All Bugs"

Actual result:
 * a rect smaller than the menu item is draw

Expected result:
 * a rect of the size of the menu item is draw

The focus ring is well draw on Firefox Desktop for both cases
Attachment #500061 - Flags: review?(mark.finkle)
Comment on attachment 500061 [details] [diff] [review]
Patch

getContentClientRects checks frames too. getOverflowContentBoundingRect doesn't, but that is probably fine for the intended use.
Attachment #500061 - Flags: review?(mark.finkle) → review+
http://hg.mozilla.org/mobile-browser/rev/74276ee97323
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
verified FIXED on builds:
Mozilla/5.0 (Maemo; Linux armv71; rv:2.0b9pre) Gecko/20101229 Namoroka/4.0b9pre Fennec/4.0b4pre

and

Mozilla/5.0 (Android; Linux armv71; rv:2.0b9pre) Gecko/20101229 Namoroka/4.0b9pre Fennec/4.0b4pre
v. from comment 4
Status: RESOLVED → VERIFIED
bugspam
Assignee: nobody → 21
You need to log in before you can comment on or make changes to this bug.