Closed Bug 621779 Opened 9 years ago Closed 9 years ago

Cannot see more than 6 tabs when VKB is opened in portrait mode

Categories

(Firefox for Android Graveyard :: General, defect, P2)

ARM
Android
defect

Tracking

(fennec2.0+)

VERIFIED FIXED
Tracking Status
fennec 2.0+ ---

People

(Reporter: ashah, Assigned: vingtetun)

References

Details

(Whiteboard: [vkb])

Attachments

(2 files, 4 obsolete files)

Attached image screenshot of 6 tabs
Mozilla/5.0 (Android; Linux armv71; rv:2.0b9pre) Gecko/20101227
Firefox/4.0b9pre Fennec/4.0b4pre

1. Open Fennec
2. Open 8 to 9 tabs
3. In one of the tab(preferable the last tab), open a webpage that has a text box (eg. www.yahoo.com)
4. Click on the textbox to bring up the virtual keyboard
5. Slide the page to the right to reveal the tabs

Actual result:
I can see only 6 tabs. I cannot pan to reveal the other tabs

Expected result:
I can see/pan all my tabs
tracking-fennec: --- → ?
Looks like exactly what bug 607841 was supposed to do.

>Expected result:
>I can see/pan all my tabs

Any thoughts on how this could be achieved? What are your expectations regarding panning while the VKB is open?
> Any thoughts on how this could be achieved? What are your expectations
> regarding panning while the VKB is open?

Not sure but may be we can allow a horizontal pan on the tabs. Because right now, there is not way I can see after 6 tabs.
Attached patch Patch (obsolete) — Splinter Review
This patch add a max-width for the tabs container and allow panning tabs if needed.

This will leave 2 columns in portrait mode and 4 in landscape mode.
Attachment #500158 - Flags: review?(mark.finkle)
tracking-fennec: ? → 2.0+
Duplicate of this bug: 624519
Assignee: nobody → 21
Attached patch Patch updated (obsolete) — Splinter Review
Updated patch on trunk, also I've removed r? since I've found a few bugs. I've give a build to Madhava to have his opinion (http://vingtetun.org/build/tabs.apk)
Attachment #500158 - Attachment is obsolete: true
Attachment #500158 - Flags: review?(mark.finkle)
Attached patch Patch (obsolete) — Splinter Review
Attachment #507597 - Attachment is obsolete: true
Attached patch Patch v0.2 (obsolete) — Splinter Review
There is a build at http://vingtetun.org/build/tabs-new.apk for those who want to try.
Attachment #508388 - Attachment is obsolete: true
Attachment #508456 - Flags: review?(mark.finkle)
Attachment #508388 - Flags: review?(mark.finkle)
Attached patch Patch v0.3Splinter Review
I have spoke with Madhava yesterday and he is agree for 2 tabs and a half on both portrait and landscape.

browser_sidebars.js still works with this patch applied.
Attachment #508456 - Attachment is obsolete: true
Attachment #511360 - Flags: review?(mark.finkle)
Attachment #508456 - Flags: review?(mark.finkle)
Attachment #511360 - Flags: review?(mark.finkle) → review+
http://hg.mozilla.org/mobile-browser/rev/40de821d2c78
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
verified FIXED on build:

Mozilla/5.0 (Android; Linux armv71; rv:2.0b12pre) Gecko/20110210 Firefox/4.0b12pre Fennec/4.0b5pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.