Status

addons.mozilla.org Graveyard
Code Quality
P4
normal
VERIFIED FIXED
8 years ago
2 years ago

People

(Reporter: Andy McKay, Assigned: Andy McKay)

Tracking

Details

(Assignee)

Description

8 years ago
If we are slugifying tags (as per 619580) then we could clean up the tags that are in the system. For example: 'foo bar', 'foo-bar', ' foo bar', ' Foo bar ' etc will all end up being the same tag.
(Assignee)

Updated

8 years ago
Blocks: 628017
Duplicate of this bug: 628017
Priority: -- → P4
Target Milestone: 4.x (triaged) → Q1 2011
Assignee: nobody → amckay
Target Milestone: Q1 2011 → 5.12.9
(Assignee)

Comment 2

8 years ago
https://github.com/jbalogh/zamboni/commit/01329476714fb8ae384847d89eb35096ec5c0848
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

8 years ago
Will need the manage.py clean_tags run for QA people to see the goodness.
(In reply to comment #3)
> Will need the manage.py clean_tags run for QA people to see the goodness.

Run, added 30000 tags to celery
(Assignee)

Comment 5

8 years ago
Sorry, just to clarify:

' Foo bar ', 'foo bar', ' foo bar' all become the same

'foo-bar' stays it's own tag since - are allowed in slugs.

Comment 6

8 years ago
verified that

* ' Foo bar ', 'foo bar', ' foo bar' become 'foo bar'
* foobar and foo bar are treated as separate tags
* hypens are allowed in tags
* 'test', 'Test', 'TEST' become 'test'
* blacklisted tags  are not allowed
* max limit is 20
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.