Opening new tab causes funny focus behavior [caused by DivX HiQ]

RESOLVED INVALID

Status

()

Firefox
Extension Compatibility
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Henry Hartley, Unassigned)

Tracking

3.6 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

Sometimes, with "When I open a link in a new tab, switch to it immediately" NOT checked, ctrl-left-clicking a link opens the new tab and changes focus. If ctrl-left-clicking in the right-most open tab, I'm switched to the newly open tab despite the setting saying not to. If on any other open tab, the new tab is opened and I'm switched to the tab one to the right of the current tab.

I've toggled the "When I open a link in a new tab, switch to it immediately" and in the other setting (On), it seems to work as expected. Then turning it back off causes the behavior to go back to the above.

Reproducible: Sometimes

Steps to Reproduce:
1. Four tabs open. 
2. Ctrl-left-click on a link in the second tab from the left.

Actual Results:  
Focus moves from tab two to tab three and the new tab is opened between that tab (three) and tab four.

Expected Results:  
New tab should open between tabs two and three and focus should remain on tab two.

I have only seen this one this one machine so it may be very version/OS/hardware specific. This is my only 64-bit Windows machine, so I really don't know.
(Reporter)

Updated

7 years ago
Version: unspecified → 3.6 Branch
(Reporter)

Comment 1

7 years ago
Usually, the first link opened in a new tab works properly. It's only if a second one is clicked on in that same page that the problem seems to occur. That is:

1. Four tabs open.
2. Ctrl-left-click on a link in the second tab from the left.
3. New tab three opens and the original tabs three and four become four and five
4. Ctrl-left-click on another link in tab two
5. Focus switches to tab three and the new tab opens between three and four. Four and five become five and six.

Hope that helps.
Does this behavior also happen in Firefox 4 Beta 8? Beside that you should also test in a fresh profile: http://support.mozilla.com/en-US/kb/Managing+profiles
(Reporter)

Comment 3

7 years ago
I disabled my extensions, created a new profile and the problem did not present. I adjusted two tabs related settings in about:config (browser.tabs.closeButton and browser.tabs.warnOnClose) to match those in my main profile but that made no difference (i.e. problem still absent). Then I turned on my extensions one by one, restarting firefox after each.

It appears that the culprit is the DivX HiQ 2.1.0.900 extension. Going back to my main profile, with that extension disabled, the problem no longer presents. I'll leave that disabled.

I have closed this bug report as invalid (since it is presumably the extension's fault).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
Thanks Henry! You can send a bug report to the extension author, so the issue can get fixed.
Component: Tabbed Browser → Extension Compatibility
QA Contact: tabbed.browser → extension.compatibility
Summary: Opening new tab causes funny focus behavior → Opening new tab causes funny focus behavior [caused by DivX HiQ]
You need to log in before you can comment on or make changes to this bug.