firefox beta 4.0 ver 8 not usingg all cores of my processer

RESOLVED INCOMPLETE

Status

()

Firefox
General
RESOLVED INCOMPLETE
7 years ago
6 years ago

People

(Reporter: Dan, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b8) Gecko/20100101 Firefox/4.0b8
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b8) Gecko/20100101 Firefox/4.0b8

I have a Asus M2n68-am plus motherboard with a Amd phenom-9600 4 core processer. The new 4.0 ver 8 is only using the first core of the processer and is maxing it out when watching streaming movies.this does not happen if i use firefox 3.6 version which i still have on the computer. And no i don`t think anyone sucks!  LOL 

Reproducible: Always

Steps to Reproduce:
1.run movies from justin.tv or hulu.com
2.
3.
Actual Results:  
first core only being used

Expected Results:  
all cores used

Comment 1

7 years ago
I'm not seeing that. I see both the firefox.exe and plugin-container.exe (where the Flash plugin is running in) running simultaneously (40% in case of justin.tv, I can't run hulu here). Scheduling is of course a matter for the OS, but I can see that both cpus are busy. There should be at least 2 different treads running (at least one in each process), possibly more, so that you should normally see at least 2 cores in use.

Do you also see both processes running ? And are you sure that they both run on the same cpu ?
(Reporter)

Comment 2

7 years ago
Firefox 3.6 is using all cores evenly as is Internet explorer 8 browser. If beta 4.0 ver 8 firefox is using all cores it isn`t doing it effeciently like other browsers.If you are running a dual core vs me running a 4 core processer and you are ok then maybe its just my system`s 4 core not compatible with 4.0 beta. I like 3.6 and it runs fine with it so I will stick with it. BTW i have tried Seamonkey and Chrome and Avant browsers and they all differ in how much the cores of my processer are utilized And mozilla 3.6 is the best for using all cores the most evenly. I run a triple booted hard drive system using Win 7 on one drive and Win Xp pro service pack 3 on a hard drive and Ubuntu 10.10 on a hard drive. I have been building systems since ms dos came out and was a radar technician for 10 years in the air force.
(Reporter)

Comment 3

7 years ago
yes i see both processes running and also the plug-in container. I am not running multi processer`s but one processer that has 4 cores<phenom>. The best browser i have found for using the L3 cache on my processer is the new Avant browser that is boosting its new dual web engine design. It also is the fastest at streaming movies.

Updated

7 years ago
Version: unspecified → Trunk

Comment 4

6 years ago
Dan -> Are you still experiencing this issue with the latest version of Firefox 5?

Comment 5

6 years ago
Closing bug as Incomplete - if you are still experiencing this issue or have more information to provide feel free to post back here and we can re-open the bug. You can also get assistance by visiting the Firefox help site -> http://support.mozilla.com/en-US/kb/Ask+a+question
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.