Mozilla hangs for a few seconds when accessing web page

RESOLVED WORKSFORME

Status

()

Core
Layout
P3
normal
RESOLVED WORKSFORME
17 years ago
4 years ago

People

(Reporter: pla, Assigned: Chris Waterson)

Tracking

(Blocks: 1 bug, {helpwanted, perf})

Trunk
Future
x86
All
helpwanted, perf
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
After clicking on news headlines news html file starts loading, it is 
approx 75 kb, after that about 10 sec. pause and CPU 100% hog. This 
bug is not in Netscape 6 or any other Mozilla's.
Using 6Dec build.

Comment 1

17 years ago
OS/2 only
Assignee: darin → mkaply
Summary: CPU 100% hog → OS/2 - CPU 100% hog

Comment 2

17 years ago
Reporter is this still a problem on the latest nightlies?
(Reporter)

Comment 3

17 years ago
Yep, bug is still up and buggy :)

Comment 4

17 years ago
Marking NEW as per comments.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

17 years ago
I had dbaron check this on Windows and it definitely happens there.

Go to www.adventuregamer.com

You might have to hit Stop so it will finish loading because of ad problems.

Then click on one of the news items under the date in the upper right corner.

Now watch the throbber.

After the page blanks, the throbber actually stops for a few seconds. Then the 
page continues loading.

The page isn't really that big - the only noticeable thing is some warnings in 
the console about table size.
Assignee: mkaply → clayton
Component: Networking: HTTP → Layout
OS: OS/2 → All
QA Contact: tever → petersen
Summary: OS/2 - CPU 100% hog → Mozilla hangs for a few seconds when accessing web page
I don't see this on Linux.  And I don't use Windows... must've been someone else?
Actually, I do see this.  Nothing in particular stands out in this profile. 
About half the time seems to be in reflow, and about 1/3 (this seems a bit much)
adding attributes in the content sink / style system.  Are there heavily nested
font tags?
Created attachment 23351 [details]
jprof profile (realtime, 1ms)
Yeah, lots of font tags.

Comment 10

17 years ago
Waterson, can have someone quantify this to help determine where to look. 
Assignee: clayton → waterson
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Keywords: perf
Target Milestone: --- → mozilla0.9.1
(Assignee)

Updated

17 years ago
Keywords: helpwanted
Target Milestone: mozilla0.9.1 → Future

Comment 11

17 years ago
The correct URL is now probably:
http://www.worldofmi.com/
But it isn't too serious it renders only 5 seconds on my Celeron 566 Linux
2001062021.
(Assignee)

Updated

16 years ago
Blocks: 103671

Comment 12

16 years ago
I do not se a hang here on linux build 20020426x. It the loading of the images
takes a while, but a 'reload' displays it almost immediately (899 MHz/256 MHz)

Comment 13

16 years ago
I agree on comments#12,but using mozilla1.0 based on win2000.
Page has been rewritten, clearly (no more <font> tags).

Marking worksforme, since there is no testcase here and we have other bugs on
deeply nested inlines being slow to reflow...
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.