Infinite SWF download on auto-refresh page with Flash

RESOLVED WONTFIX

Status

Fennec Graveyard
General
--
major
RESOLVED WONTFIX
7 years ago
7 years ago

People

(Reporter: Isriya Paireepairit, Assigned: azakai)

Tracking

Trunk
ARM
Android

Details

(Reporter)

Description

7 years ago
Summary: Since Firefox Mobile can't display Flash and try to download .swf file instead, on the auto-refresh web page with Flash object, Firefox will download .swf file infinitely if the web page left opened.

Step to reproduce:

- Open Firefox Mobile
- Go to livescore.com
- Wait and see the infinite download loop everytime the web site is auto-refreshed.

Firefox Mobile 4.0 Beta 3 on Samsung Galaxy Tab with Android 2.2
We shouldn't be allowing users to download flash since it's not enable-able on Fennec.
tracking-fennec: --- → ?

Updated

7 years ago
Assignee: nobody → doug.turner
tracking-fennec: ? → 2.0+

Updated

7 years ago
Assignee: doug.turner → azakai
(Assignee)

Comment 2

7 years ago
Do we really not want to allow downloading Flash? Flash might be run in a standalone player. This is what happens on a Galaxy S and on Linux desktop.

Comment 3

7 years ago
aakash, can you still reproduce this?
(Assignee)

Comment 4

7 years ago
The situation is this: The page has a Flash element in it that seems to do nothing. That is, when loaded in the stock browser (not Fennec), you get the symbol for a Flash element, but nothing runs.

In Fennec, we pass off the Flash element to the Android native Flash app. That app appears and shows the same Flash symbol.

I think Fennec is doing the best it can at this point - we pass off Flash to the native Flash app. Currently the Flash doesn't actually do anything useful, but if it were working, this would be the proper behavior - since Fennec doesn't have the capability to run embedded Flash (due to multiprocess issues and so forth).

There is the other issue of the loop - apparently the page auto-refreshes itself, which leads to the Flash being reloaded, which leads to us re-launching the native Flash app. This is not good behavior, but I do not see what we can do to fix it. We don't want to block downloading Flash altogether because it is the right behavior in other cases. We could, perhaps, add an option to block Flash downloads after they happen more than a certain amount of times - like, say, we do for alert()s. This seems to be a very rare situation, though, so I recommend that we pass on doing anything here for now.

Feel free to reopen if my analysis here is wrong somehow and there is something better we should do.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.