Remove support for tagging bookmarks

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
8 years ago
6 years ago

People

(Reporter: philikon, Unassigned)

Tracking

({dataloss})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [killthem])

I'd love to get some data on how many people tag their bookmarks (I volunteer writing a test pilot study for it if we don't have this data yet), but I'm willing to bet even power users generally don't. So unless the data suggests it's a feature worth keeping, I propose removing support for bookmark tags.
Whiteboard: [killthem]
We used to have data on places-stats.mozilla.com, but that doesn't appear to resolve anymore.  I've filed bug 622095 about that so we can get to that data.
no way. you crazy, man.
the fact we have a sucking tagging UI is probably not enough to remove a feature like tags
(In reply to comment #3)
> the fact we have a sucking tagging UI is probably not enough to remove a
> feature like tags

Never said that the sucky UI was the (only) reason. It's a feature that complicates Places and Sync code a lot. It seems pointless to keep supporting it in new APIs and new code (not to mention tests and Q&A) when it's hardly used by anybody. We can debate about whether or not that's the sucky UI's fault, but I would question the benefit of the actual feature compared to the maintenance cost it has.
If handling tag-related fields in sync is difficult, the underlying database schema might need to be reworked / optimized for syncability.

We should still get some data on users who use tags and how much though. I expect more people might use tags if the interface was better. Then again, I use tags because the folder system is such a pain to use.
(In reply to comment #5)
> If handling tag-related fields in sync is difficult, the underlying database
> schema might need to be reworked / optimized for syncability.

The underlying schema is the worst schema I've ever seen to manage tags, this is known and causes issues to the backend as well, but it's not a reason to drop the feature, we just have to fix it.

Comment 7

8 years ago
I use tags a lot (and the shortcuts to filter awesomebar results).

Please note that while power users might not be more than a fraction of the total number of users, we are more inclined than the average user top tweet, blog or in conversation with our friends recommend or not recommend a specific browser.

I've installed Firefox on at least 20 computers for friends and family. My guess is that none of them tag their bookmarks, but I do, and my satisfaction with the browser would decrease if it went away.

How do one measure such factors?
FWIW, I wish bookmark and tagging support was *better* in Firefox, not removed. I don't use bookmarks in Firefox much at all because they just don't work all that well for me. So, my usage data would support removing tags and dumbing down bookmarks—when what I've wanted all along is an improved feature, not its absence.

Granted, I'm an outlier with 16k+ bookmarks in Delicious / pinboard.in, so maybe that takes me out of the main audience.
(In reply to comment #8)
> FWIW, I wish bookmark and tagging support was *better* in Firefox, not removed.

Summarizing what I've written in bug 622049 comment 10 and bug 622045 comment 11:

This is an easy argument to make while not helping much. We all wish the browser would do this and that. So it becomes a trade-off: would we rather do something in a mediocre way, suffer the maintenance cost while continuing to wish we did it better. Or just cut the feature and leave the space to something that actually does it better. Like services on web, for instance.

> I don't use bookmarks in Firefox much at all because they just don't work all
> that well for me. So, my usage data would support removing tags and dumbing
> down bookmarks—when what I've wanted all along is an improved feature, not its
> absence.
> 
> Granted, I'm an outlier with 16k+ bookmarks in Delicious / pinboard.in, so
> maybe that takes me out of the main audience.

I think you just proved my point from above :)

Comment 10

8 years ago
(In reply to comment #9)
> (In reply to comment #8)
> > FWIW, I wish bookmark and tagging support was *better* in Firefox, not removed.
> 
> Summarizing what I've written in bug 622049 comment 10 and bug 622045 comment
> 11:
> 
> This is an easy argument to make while not helping much. We all wish the
> browser would do this and that. So it becomes a trade-off: would we rather do
> something in a mediocre way, suffer the maintenance cost while continuing to
> wish we did it better. Or just cut the feature and leave the space to something
> that actually does it better. Like services on web, for instance.

I think you are looking at it wrong. The right approach is to first have a clear and coherent vision about what the essential part of browsing experience are and to design based on that. In this case, tagging was introduced in Firefox 3 as part of a broader set of ideas, which included the Awesomebar, one-click bookmarking to Unsorted Bookmarks folder etc. Going through features separately and randomly deciding which to cut based on their popularity and quality of implementation doesn't seem like the right path.

> > I don't use bookmarks in Firefox much at all because they just don't work all
> > that well for me. So, my usage data would support removing tags and dumbing
> > down bookmarks—when what I've wanted all along is an improved feature, not its
> > absence.
> > 
> > Granted, I'm an outlier with 16k+ bookmarks in Delicious / pinboard.in, so
> > maybe that takes me out of the main audience.
> 
> I think you just proved my point from above :)

Well, there is plenty of room between the extremes. I have a few hundred bookmarks and I use tags regularly - I find the existing features suitable for my needs, I just wish they were more polished.
(In reply to comment #10)
> (In reply to comment #9)
> > This is an easy argument to make while not helping much. We all wish the
> > browser would do this and that. So it becomes a trade-off: would we rather do
> > something in a mediocre way, suffer the maintenance cost while continuing to
> > wish we did it better. Or just cut the feature and leave the space to something
> > that actually does it better. Like services on web, for instance.
> 
> I think you are looking at it wrong. The right approach is to first have a
> clear and coherent vision about what the essential part of browsing experience
> are and to design based on that.

You are assuming I don't have a clear and coherent vision about web browser essentials. Just for fun, let's say I did, then it certainly wouldn't include tagging bookmarks.

> In this case, tagging was introduced in
> Firefox 3 as part of a broader set of ideas, which included the Awesomebar,
> one-click bookmarking to Unsorted Bookmarks folder etc. Going through features
> separately and randomly deciding which to cut based on their popularity and
> quality of implementation doesn't seem like the right path.

Most features were put into the browser at some point based on a clear plan and vision. *Then*. Things change. My call for feature removal may seem random, but I can assure you there's method in my madness. The vision I have is shipping an awesome browser with features that are relevant *now*. Feeds and tags and what have you may have seemed relevant back when Firefox 3 was designed (at least to some people), but it's ok to come to the conclusion that they aren't now.

Particularly with a rarely used and hard to maintain feature, we need to make this trade-off: does it make a better browser if we kept this feature rather than spending the time it takes to maintain it on improving other features? If the answer is no, it's probably time to drop it.

Comment 12

8 years ago
OK, let me start again.

Of course we shouldn't attempt do everything and we should leave many things to extensions and web apps. However, we must discuss and clearly define the general focus and direction before deciding what to cut and what to improve. Meanwhile, between bug 622049 and this one it seems like we are going at it backwards and discussing each feature in isolation, citing maintenance burden and (alleged) lack of popularity as arguments, with holistic arguments limited to vague "we can't do everything well." This can fly for little things, not for major features. If nothing else, the community would raise absolute hell.

The direction taken in Firefox 3 was to make it easy to quickly bookmark interesting pages, to promote search over browsing, and to encourage annotating with tags over arranging in hierarchy. All these things were considered complementary, so if tags didn't catch on then either it is caused by a poor implementation or we based the design on some faulty assumptions. In the former case we should improve the implementation instead of taking it out, in the latter we must re-examine the whole design.
I understand where you're coming from, but your all-or-nothing mandate is not particularly helpful in solving the problem of engineering resource vs. feature support. We're dealing with a grown system. It's always easy to demand that we can't just remove a particular feature but instead need to rethink the *whole* system or "just" improve that feature. Unfortunately all this does is (probably unintentionally) provide stop energy. It does not solve the problem of efficiently spending engineering efforts.

That said, I tried to allude in comment 11 and previous comments that I do have an overall theme for this "redesign": remove features from the browser that cause a great deal of maintenance cost and are probably done better in a different space (e.g. the web). These happen to be IMHO four particular features (tags, livemarks, smart bookmarks, microsummaries) for which I have filed individual bugs.
(In reply to comment #12)
> In the former case we should improve the implementation instead
> of taking it out, in the latter we must re-examine the whole design.

False dichotomy.

This is software: there's no reason why we can't:

1. Rip out the implementation that users don't use, that is costly to maintain, and doesn't work so well

2. Explore a better implementation, in a branch or in an add-on... or encourage the community to do so

3. Consider how to provide a better approach (either in an add-on or a future release), given what we've learned so far.

*All at the same time*.

If we ripped out or rescoped smart bookmarks, tagging, live bookmarks, and microsummaries we'd have a faster, simpler browser, and most people wouldn't even notice. It'd be easier for us to maintain, we'd have fewer bugs, services like Sync would be quicker, more reliable, and easier to build, and we'd be able to put our time into speed improvements and other features.

As a handy side-effect, it would discourage people from using the infrastructure in a way that least suits it -- e.g., as a high-volume RSS reader -- and getting a bad impression of Firefox as a result.

We might find that the best solution is to develop pinboard.in, Google Reader, etc. add-ons... or something else entirely.

The alternative is to continue to spend man-months of time supporting complex, hard-to-test features across a range of components and services, rather than working on things that people will actually appreciate.

This is not to say that Mozilla doesn't have anything to contribute to these spaces... but in core Firefox? Probably not the best place for an RSS subscription engine, or a tag-based bookmark system. We have a services division, and the web is a big place.
imo this is wontfix, and I don't figure out why managing tags would be so hard for Sync, it's easy to manage them with a simple json file. Could be easier or even trivial just by changing the schema.
And I don't see the value of starting long discussions like this one in a bug, these bugs should be opened after the discussion brought to something.
Can we bring kill-any-feature-we-have discussions to an appropriate newgroup please?
(In reply to comment #9)
> (In reply to comment #8)

> > Granted, I'm an outlier with 16k+ bookmarks in Delicious / pinboard.in, so
> > maybe that takes me out of the main audience.
> 
> I think you just proved my point from above :)

Philipp, are you not building a web service for storing bookmarks and associated data? I would like one day to be able to share my data using Sync. Tags and all.

See anantn's Slurp extension which has the ability to import Les' 16k bookmarks and metadata into Firefox. People using that as a backup mechanism (like myself) would suddenly find their data disappear? This is a little different from removing a menu item or a UI element.
Keywords: dataloss
ps, maybe a dev.apps.firefox or usability thread is in order to open this discussion up outside of this bug. I'm keenly aware that I'm advocating here and this isn't really the forum for it.
(In reply to comment #17)
> ps, maybe a dev.apps.firefox or usability thread is in order to open this
> discussion up outside of this bug. I'm keenly aware that I'm advocating here
> and this isn't really the forum for it.
Yes, that'd be the correct place for it (see also: comment 15)

Comment 19

8 years ago
I'm stunned.  

I'm a software developer and along with the expected glut of applications associated with that line of work, I'm also an amateur photographer and music collector.  What I'm saying is that I've used untold zillions of applications that support tagging.

Of all of them, Firefox's tagging UI is the only one I love.  It is also the only one I don't hate.  It is exactly what I want.  Painless tagging and fast, painless retrieval via the Awesomebar. 

Firefox's tagging support is the sole reason I use FF instead of Chrome.  I really cannot comprehend the concept of somebody using the web for daily research without a mechanism to tag their bookmarks.  Bookmarks are nearly useless to me without tags, since a page's title doesn't necessarily reflect its content. (Or, more to the point, it may reflect the page's content but not the bit of information that caused me to bookmark it)

I am stunned that this is a candidate for deletion.  The RSS icon, Live Bookmarks, yes, I understand the reasons for phasing those out well even though I find those features useful.

Comment 20

8 years ago
Prior to the introduction of tags my bookmarks were a mess of duplicates as the strict hierarchical structure forced me to bookmark something multiple times if I wanted it in the "Hardware" and "Games" folders, for example.

Tagging has allowed me to have complex overlaps between bookmarks whilst storing them only once.

If tags are removed, is there any plan to offer an alternative mechanism for dealing with this sort of issue (other than reimplementing tags in an add-on), or will I be back to duplicate bookmarks dotted throughout the hierarchy?

Personally I would prefer improved tagging _instead_ of an enforced hierarchical UI. The appearance of a folder structure could be dynamically constructed from the tags such that it doesn't matter if I dig into "Games" then "Hardware" or "Hardware" then "Games", I'd still get to the same tagged bookmarks.

Comment 21

8 years ago
I, also, don't understand the presumption that the Firefox tag UI is "sucky."  It is really nonintrusive, easy to use, and if you tag something intuitively you don't even have to remember exactly what to find it again -- it'll just come up as you use the awesomebar search.

I don't use it very often, but it is a pretty important part of the browser UI to me -- and I'd certainly never have thought to seek out such functionality in an add-on.  In contrast, I never ever use folders anymore.

Comment 22

8 years ago
I for one, very much appreciated the existence of tags in Firefox bookmarks. 
Thanks to the awesome bar, I gave up filing my bookmarks a long time ago.  The
only time I open "Organise bookmarks" is to delete a bookmark which is out of
date but still appears near the top of awesome bar searches.

Most of the time it is sufficient to just add a bookmark and be done with it. 
The awesome bar will find what I am looking for as long as it is in the web
page's URL or title.  However, it a quite common case that the key (to me) term
isn't included in either the URL or the title.  In which case, I add a tag as a
mnemonic.  My tags are quite arbitrary and totally based on my current context.
 I guess I could edit the bookmark title to include the terms, but tags are a
much more intuitive way of doing this.

Comment 23

8 years ago
Agree with the above commenters. Tagging bookmarks is the killer feature of Firefox and shouldn't be removed. This is the area where Firefox is superior to other browsers. I'd rather have no Sync, than having my bookmarks hard to find because they aren't tagged anymore.
It's great that everyone feels the need to express their opinion, but bugzilla is not the place for that (per bugzilla etiquette: https://bugzilla.mozilla.org/page.cgi?id=etiquette.html).  Please take the discussion to dev.apps.firefox: https://www.mozilla.org/about/forums/#dev-apps-firefox
(In reply to comment #24)
> It's great that everyone feels the need to express their opinion, but bugzilla
> is not the place for that (per bugzilla etiquette:
> https://bugzilla.mozilla.org/page.cgi?id=etiquette.html).  Please take the
> discussion to dev.apps.firefox:
> https://www.mozilla.org/about/forums/#dev-apps-firefox

FWIW, I started this thread to try to move discussion there:

http://groups.google.com/group/mozilla.dev.apps.firefox/browse_thread/thread/fa6f83e781b962a4
This is one of the key selling points of Firefox. If tagging is removed, I might as well move to Chrome. It is one of the few things that is still unique about Firefox. So no, do not remove it, but enhance it instead, as Chrome will no doubt be incorporating tagging sometime in the future.

Comment 27

8 years ago
I actually rely on my tags.

Comment 28

8 years ago
I don't feel one or or another about the UI.

I don't tag bookmarks because Firefox is incapable of either exporting or importing tags.
* You spend ages neatly tagging your bookmarks, you export them (in HTML format), then when you import them again, your tags are missing.
* You use social bookmarking sites like del.icio.us. You export your bookmarks complete with tags, import them in Firefox, and again your tags are missing.
It's hardly surprising that people don't use a broken feature. Submitting that as an argument for the feature's removal is lazy at best, and ludicrous at worst.

On a more general note, I'm quite fed up with the "use an extension for that" developer mantra. The burden has fallen on extension authors to fix every bug and shortcoming under the sun. Either do things right the first time, or don't bother doing them at all. That way, at least there wouldn't be any users who find their favorite features removed.

Comment 29

8 years ago
(In reply to comment #28)
Have you filed bugs for the missing tagging import/export support?

Comment 30

8 years ago
(In reply to comment #29)

The bugs have been filed more than 3 years ago:

Bug 423197 - html export does not back up tags
Bug 416611 - support importing tags from bookmarks.html exports (del.icio.us and others)

Even thou I can't export tags to other software I still use them heavily, please do not remove tags from Firefox.

Comment 31

8 years ago
(I haven't read through the comments)

I use tags mostly to use them with AwesomeBar, very rarely with Library (but then it's Library that I use rarely, not tags). Most (if not all) of my tags are of three kinds: “to do” (to mark something that needs or may need attention later), “I did” (to mark my comments), “search keyword” (when title lacks the keyword I’d use to search).

Compared to titles, tags have the advantage of visibility in the bookmarking dialog: when I click the star, I see why I bookmarked the page, so I don’t lose the tags by removing a bookmark of which I forgot the reason I added it.

Comment 32

8 years ago
A lot of people are using tags. Please close this bug as WON'T FIX.

I hate seeing power features going away. Firefox usage stop growing up quickly. Removing features is the best way to leave Firefox as a niche browser.

Each time a new version of Firefox comes out of the door, these days, I need to say bye to some features that I used and relied on for years.

Comment 33

7 years ago
Interesting reading, I'm looking for a bug, that can be described this way:

When I rename a bookmark tag and sync the changes, it leads to the creation of a new tag with the new name on both browser instances. The old tag with the old name lives on and appears everywhere I synced as well. Some bookmarks keep the old tag and some have the new one.

I haven't tried to reproduce it yet, but I'd like to know if this could be one of the difficulties mentioned about the maintainability of the bookmark tags feature.

I'm definitely a power user, a mild one, but I'd certainly hate to see tags go. The feature helps me find things especially through the Awesome Bar.

Does any of you know if such a bug has already been reported?

Comment 34

7 years ago
It's hard to imagine the bookmarks these days without tags, but easy to imagine the new SocialAPI re-introducing some form of tagging. I'd hope there would be more of an integrated approach between the two instead of one replacing the other.

Comment 35

7 years ago
i hope this bug will be closed as INVALID.

Comment 36

6 years ago
Tags in bookmarks is the reason I'm staying with Firefox instead of going to Google Chrome, especially after FF sync deleted tons of booksmarks.  I organize my bookmarks carefully with folders and subfolders etc., but tags help me to easily identify what sets each link apart from the one in the folder with it.  It also is extremely valuable in searching bookmarks or just typing the tags in my mobile device's location bar and making that bookmark pop up.

What I would like to see is the backup and export features do a true backup of the tags with the bookmarks.  When I had to restore, none of the tags came back which is so frustrating, I signed up for Google Chrome but only came back, as I said above, because it had no tags feature.
(In reply to Erin Blackwell from comment #36)

> What I would like to see is the backup and export features do a true backup
> of the tags with the bookmarks.  When I had to restore, none of the tags
> came back which is so frustrating

Tags are present in the automatic backups that Firefox makes of your bookmarks. They're not present in exported HTML.

Comment 38

6 years ago
Unbelievable.What's next,removing the Library altogether?
If anything,a workaround to include tags in exported HTML bookmarks should be studied (if at all possible),and while on this,queries to the Library (smart folders) should be put back along with new advanced search criteria.
This is a web browser,not just an app to access social sites,a fully functional bookmarks managing interface belongs here.
Ok, I think this went far enough. it was a good proposal with clearly good points, but was discussed enough and at this time we don't intend to do that. We intend to improve the implementation to solve the issues, since that is not hard.  If we'll ever decide to reopen the discussion in future, we'll do on moz.dev.platform newsgroup first, and on bug once a decision has been agreed upon.

Please avoid commenting further unless you have something really meaningful to add to the topic.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX

Comment 40

6 years ago
 (In reply to Lars Gunther from comment #7)
> I use tags a lot (and the shortcuts to filter awesomebar results).
 
And this is another excellent point,tags *do* actually help when using the awesome bar,so instead of removing them the effort should go in more tutorials to encourage less advanced users to take advantage of them as well.
You need to log in before you can comment on or make changes to this bug.