Customize toolbars palette window should be a tab

RESOLVED FIXED

Status

()

Toolkit
Toolbars and Toolbar Customization
--
enhancement
RESOLVED FIXED
8 years ago
3 years ago

People

(Reporter: alta88, Unassigned)

Tracking

({uiwanted})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
as popup standalone windows seem to be going away, a la addons manager, perhaps this should be applied to the customization palette.

benefits:
- get rid of the awkward 'sheet' for mac.
- get rid of fixed 4 items per row in favor of a flow/wrapped list.

a preview of this behavior can be found in this extension:
http://downloads.mozdev.org/totaltoolbar/TotalToolbar-1.8b5.xpi

if this is deemed desirable, i'd be glad to make a patch.
I think this could be very cool. Adding ui-wanted to get broader feedback.
Keywords: uiwanted
That would require hot-swapping between visible toolbars, and the customize view. Also it should probably be limited to a single tab, similar to what we are doing with the add-ons manager. Clicking the menu entry to Customize the toolbars again in another tab, should select the tab with the customize options already shown.

Would be great to get some feedback from UX.

Comment 3

8 years ago
Currently in customize mode the menubar and all toolbar buttons are disabled. I would suggest disabling the tabbar (or the ability to switch tabs) as well if we put the customize palette in a tab.
We do want to move the customization window into a tab (along with everything else, like the library window, etc.)  However, we want to also do a pretty significant redesign at the same time.  For instance, you apply a persona and customize the toolbar controls in totally different places in our UI right now.  Placing tabs on top is done in a third place.  We need to unify everything related to customization into a single UI, and also deal with some of the issues with the interface not being modal.

Comment 5

8 years ago
FYI:

Toolbar customization is in toolkit and shared with Thunderbird and SeaMonkey and possibly other gecko based apps. Personas code live in each app - SeaMonkey and Thunderbird support personas, other apps might not. Tabs on top - at the moment only Firefox has this and there is no timeframe in either Thunderbird nor SeaMonkey to support this. And not every toolkit app with customizable toolbars have tabs even. Most of the primary windows in SeaMonkey and Thunderbird that have customizable toolbars (Addressbook, Message Compose, etc) aren't tabbed either.
Duplicate of this bug: 686183

Comment 7

3 years ago
(In reply to alta88 from comment #0)
> as popup standalone windows seem to be going away, a la addons manager,
> perhaps this should be applied to the customization palette.

Firefox has reached this request with the "Australis" design since version 28.
 
> benefits: ...
> - get rid of fixed 4 items per row in favor of a flow/wrapped list.

In current Seamonkey the dialog box is resizeable and the icons flow according to the width of the box. 

If for Thunderbird or Seamonkey this feature is wanted, another request may be filed.

Personally I disagree with this because web pages and browser control dialogs are getting much to similar.  If you ask an average Australis using grandma if she is currently on a webpage or if she is on a page to control (and perhaps destroy) her Firefox you won't get a clear answer.  And that is bad.

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.