Closed Bug 622194 Opened 11 years ago Closed 11 years ago

Animated GIF just flashes instead of proper animation

Categories

(Core :: Layout: Images, Video, and HTML Frames, defect)

x86_64
Linux
defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: monochromec, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.16) Gecko/20101206 SeaMonkey/2.0.11
Build Identifier: 2.0.11

When displaying a multi-layered GIF (aka "animated GIF"), Seamonkey just displays the first image of the sequence and then flashes the images instead of properly displaying the sequence as defined by the individual layers.

Reproducible: Always

Steps to Reproduce:
1. Open a bug report in Bugzilla
2. Watch the dinosaur (just displays first image instead of catching the bug)
3.
Actual Results:  
First image of sequence

Expected Results:  
Full sequence resulting in animated GIF

Does not happen in Firefox 3.6.13 nor in the Windows version of 2.0.11
You're using an antediluvian Gecko version.  Please test something based on at least Gecko 1.9.2, or better yet on 2.0 betas.  I distinctly recall this being fixed sometime in the several years since Gecko 1.9.1 shipped.
Checked with the 2.1 beta 1 (albeit 32 bit). Bug seems to be fixed as I couldn't reproduce the problem. Thanks for the hint!
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.