Closed Bug 622243 Opened 9 years ago Closed 9 years ago

SelectHelperUI code hang fennec if the <select/> contains too much data

Categories

(Firefox for Android Graveyard :: General, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: vingtetun, Assigned: vingtetun)

Details

Attachments

(1 file)

Attached patch PatchSplinter Review
Steps to reproduce:
 * go to https://bugzilla.mozilla.org/query.cgi
 * click on the "product" select
 * click the next arrow of the form assistant

Expected result:
 * Fennec moved to the next field

Actual result: 
 * Fennec hang
Attachment #500491 - Flags: review?(mbrubeck)
Attachment #500491 - Flags: review?(mbrubeck) → review+
http://hg.mozilla.org/mobile-browser/rev/27b09b4c1f77
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
verified FIXED on build:
Mozilla/5.0 (Android; Linux armv71; rv:2.0b9pre) Gecko/20100104 Namoroka/4.0b9pre Fennec/4.0b4pre

...but when performing a search in the form assistant combobox UI, there's some real performance issues. Is this related?
Status: RESOLVED → VERIFIED
(In reply to comment #2)
> verified FIXED on build:
> Mozilla/5.0 (Android; Linux armv71; rv:2.0b9pre) Gecko/20100104
> Namoroka/4.0b9pre Fennec/4.0b4pre
> 
> ...but when performing a search in the form assistant combobox UI, there's some
> real performance issues. Is this related?

This is not related, at least not with the fix of this bug. The problem is probably because of the amount of data, if you open a bug I could have a look at it but this is definitively not a priority (i think)
bugspam
Assignee: nobody → 21
You need to log in before you can comment on or make changes to this bug.