Closed Bug 622309 Opened 10 years ago Closed 8 years ago

email address with trailing whitespace in contact's email field [foo@bar.com ] parsed wrongly when entered as recipient ["foo"@bar.com] (added double quotes cause email rejection)

Categories

(Thunderbird :: Address Book, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 286760

People

(Reporter: whebert, Unassigned)

Details

User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; GTB6.6; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C)
Build Identifier: Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/20101207 Thunderbird/3.1.7

if the address book entry for the email address has an extra space at the end of the address, then the program will put double quotes aroung the name when sending email.  ie:  "billhebert"@tampabay.rr.com      will be used instead of   billhebert@tampabay.rr.com

Reproducible: Always

Steps to Reproduce:
1.make address book email address end with a blank (space)

2.send email to entry
3.email gets rejected
This bug is still alive november 2012 and not even confirmed almost two years later!
I confirm I can reproduce it under TB V.16.0.2
Bill, Claude, can you provide more details and an example where the space in the email address should be for things to go wrong? Use square brackets to delimit the address, like [emailwithspace @asdf.com], or [emailwithspace@asdf.com ]
>>can you provide more details 

C'mon, what detail dou you need more?
Just add any number of spaces after any address in any addres book and try to send a message to this address. You'll see the double quotes.
(In reply to Claude Schnéegans from comment #3)
> >>can you provide more details 
> 
> C'mon, what detail dou you need more?

Claude, thanks for answering quickly, that's helpful.
I was asking for more detail because STR of comment 0 and your comment 3 are incomplete, and thus I was not able to reproduce the bug.

> Just add any number of spaces after any address in any addres book and try
> to send a message to this address. You'll see the double quotes.

Unfortunately, not always. Try this:
1) have AB entry with following email address (extra spaces at end of email address):
[foo@bar.com ]
2) In AB, select AB entry, click "Write"
-> everything works like a charme. No quotes, no extra spaces added in composition (but spaces are saved in AB, causing this bug in other scenarios, only if you use other methods of write-to, esp. autocomplete)

So both summary and comment 0 are not very good, making it harder to understand and fix this bug.
OS: Windows 7 → All
Hardware: x86 → All
Summary: double quotes cause email rejection → email address with trailing whitespace in contact's email field [foo@bar.com ] parsed wrongly when entered as recipient ["foo"@bar.com] (added double quotes cause email rejection)
Details matter: More precise summary (the problem starts with trailing space, not with the quotes) reveals that this is a dupe of bug 286760 which is looking for somebody to update an almost finished patch.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 286760
>>-> everything works like a charme. No quotes, no extra spaces 

Sorry, I didn't even know there was another way to send messages.
I always write the message first, then select the addresses in the AB.
This is the way extra spaces cause a problem.
You need to log in before you can comment on or make changes to this bug.